Project

General

Profile

Feature #11451

Bookmark searches should only need to be unique within their controller

Added by Alon Goldboim almost 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1247984
Description of problem:
In Satellite 6, I can bookmark searches. These bookmarked search are coupled to a controller in which they are available.

I can make a search in the puppetclasses controller named 'ntp' for example, to search for the ntp class. The fact that the name of the bookmarked search needs to be globally unique means that I cannot create another bookmarked search for the lookup_keys controller named 'ntp' (which I'll probably want to do, since it's similar content as puppetclasses).

Version-Release number of selected component (if applicable):
foreman-1.7.2.32-1.el7sat.noarch

How reproducible:

Steps to Reproduce:
1. Create bookmarked search called 'ntp' in puppetclasses controller
2. Try to create a bookmarked search in another controller with the same name
3.

Actual results:
Cannot save second search

Expected results:
Bookmarked search should only need to be unique within the context of a single controller. Then I could save a second bookmarked search in the lookup_keys controller called 'ntp' as well.

Additional info:


Related issues

Related to Foreman - Bug #13109: Bookmark seeding ignores controller when checking for existing recordsClosed2016-01-11

Associated revisions

Revision a5a7bc71 (diff)
Added by Alon Goldboim almost 4 years ago

Fixes #11451 - Changed bookmark name to be unique per controller.

History

#1 Updated by The Foreman Bot almost 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2631 added
  • Pull request deleted ()

#2 Updated by Dominic Cleal almost 4 years ago

  • Category set to Web Interface
  • Assignee set to Alon Goldboim
  • Legacy Backlogs Release (now unused) set to 63

#3 Updated by Alon Goldboim almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #13109: Bookmark seeding ignores controller when checking for existing records added

Also available in: Atom PDF