Project

General

Profile

Feature #123

Sort list of assigned classes

Added by Frank Sweetser about 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

It would be great if, when creating or editing a host, the list of Puppetclasses assigned to that host were listed in alphabetically sorted order, rather than the order in which they were added to the host.


Related issues

Related to Foreman - Feature #66: Add Logic to host edit pageClosed2009-11-05
Is duplicate of Foreman - Refactor #193: move hosts controller away from ASClosed2010-03-25

History

#1 Updated by Ohad Levy about 10 years ago

we are planning to redo the create/edit page (and to phase out active scaffold where it make sense).

patches are welcomed ;)

#2 Updated by Ohad Levy about 10 years ago

  • Target version set to 0.1-4

#3 Updated by Marcello de Sousa almost 10 years ago

May I suggest adding "columns" to the class list. On the columns, next to the "class name" you could list "module" and "environment" where the class belongs to. You could then sort clicking on the specified column.

#4 Updated by Ohad Levy almost 10 years ago

Marcello de Sousa wrote:

May I suggest adding "columns" to the class list. On the columns, next to the "class name" you could list "module" and "environment" where the class belongs to. You could then sort clicking on the specified column.

yep, thats the plan

#5 Updated by Ohad Levy almost 10 years ago

  • Target version changed from 0.1-4 to 0.1-5

This would be easy once we get rid of ActiveScaffold, which is planned for 0.1-5

#6 Updated by Ohad Levy almost 10 years ago

  • Status changed from New to Closed

Also available in: Atom PDF