Project

General

Profile

Bug #12667

Plugins fail to seed provisioning templates

Added by Lukas Zapletal about 4 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Templates
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Due to changes in protected attributes, plugin seed script (bootdisk, discovery) now fails with:

Can't mass-assign protected attributes: locked


Related issues

Is duplicate of Foreman - Bug #12666: Mass assignment should be allowed for locked attribute of templateClosed2015-12-02

History

#1 Updated by Dominic Cleal about 4 years ago

  • Is duplicate of Bug #12666: Mass assignment should be allowed for locked attribute of template added

#2 Updated by Dominic Cleal about 4 years ago

  • Status changed from New to Duplicate

Bootdisk was already changed in https://github.com/theforeman/foreman_bootdisk/commit/793648ecfcd87f75d4f953914bfd2b03ee346f33 to avoid mass-assignment.

However #12666 will put it back as mass-assignment of locked is used in the API. I don't know that I'd suggest relying on it though.

#3 Updated by Lukas Zapletal about 4 years ago

Something wrong is with my custom google search, I need to fallback to Redmine search. Thanks.

Also available in: Atom PDF