Project

General

Profile

Bug #14028

Routing errors due to missing graphics/fonts on navigating smart-proxy page

Added by Brad Buckingham almost 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Bugzilla link:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1313806
Description of problem: On navigating the smart-proxy page, production.log filled with following routing errors:

2016-03-02 12:34:01 [app] [I] Started GET "/assets/fonts/bootstrap/glyphicons-halflings-regular.woff" for 10.65.193.200 at 2016-03-02 12:34:01 +0100
2016-03-02 12:34:01 [app] [F] | ActionController::RoutingError (No route matches [GET] "/assets/fonts/bootstrap/glyphicons-halflings-regular.woff"): | actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call' | actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'

2016-03-02 12:34:01 [app] [I] Started GET "/assets/sort_asc.png" for 10.65.193.200 at 2016-03-02 12:34:01 +0100
2016-03-02 12:34:01 [app] [F] | ActionController::RoutingError (No route matches [GET] "/assets/sort_asc.png"): | actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call' | actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call' | railties (4.1.5) lib/rails/rack/logger.rb:38:in `call_app'

2016-03-02 12:34:01 [app] [I] Started GET "/assets/sort_both.png" for 10.65.193.200 at 2016-03-02 12:34:01 +0100
2016-03-02 12:34:01 [app] [F] | ActionController::RoutingError (No route matches [GET] "/assets/sort_both.png"): | actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call' | actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call' | railties (4.1.5) lib/rails/rack/logger.rb:38:in `call_app'

2016-03-02 12:34:01 [app] [I] Started GET "/assets/fonts/bootstrap/glyphicons-halflings-regular.ttf" for 10.65.193.200 at 2016-03-02 12:34:01 +0100
2016-03-02 12:34:01 [app] [F] | ActionController::RoutingError (No route matches [GET] "/assets/fonts/bootstrap/glyphicons-halflings-regular.ttf"): | actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call' | actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'

Version-Release number of selected component (if applicable):
Satellite 6.2 snap1

How reproducible:
always

Steps to Reproduce:
1. Navigate to Infrastructure -> smart-proxies ->select default proxy
2.
3.

Actual results:
routing errors due to missing graphics and images

Expected results:
on navigating 'smart-proxies' no error should be thrown in production.log

Additional info:


Related issues

Related to Foreman - Feature #7230: Upgrade Ruby on Rails to 4.1Closed2014-08-22
Related to Foreman - Bug #14393: Missing icons on smart_proxy/show pageClosed2016-03-30

Associated revisions

Revision 3ae0173e (diff)
Added by Dominic Cleal almost 4 years ago

fixes #14028 - use image-url for data table asset URLs

Revision 898bb442 (diff)
Added by Dominic Cleal almost 4 years ago

fixes #14028 - use image-url for data table asset URLs

(cherry picked from commit 3ae0173ec97a4688d6d67928e3b72bbfe208b91e)

History

#1 Updated by Dominic Cleal almost 4 years ago

#2 Updated by Dominic Cleal almost 4 years ago

  • Category set to Web Interface
  • Status changed from New to Assigned
  • Assignee set to Dominic Cleal
  • Legacy Backlogs Release (now unused) set to 71

Can't reproduce the font error, that's unlikely to be from Foreman itself.

#3 Updated by The Foreman Bot almost 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3273 added

#4 Updated by Dominic Cleal almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by The Foreman Bot over 3 years ago

  • Pull request https://github.com/theforeman/foreman/pull/3375 added

#6 Updated by Ondřej Pražák over 3 years ago

  • Related to Bug #14393: Missing icons on smart_proxy/show page added

Also available in: Atom PDF