Project

General

Profile

Bug #143

SSL url for reports

Added by Karl Pietri almost 12 years ago. Updated almost 12 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

There is another bug similar to issue #129. On the hosts list the link to the report is correct, but when i click on it it takes me to http instead of https

    <td class="last_report-column " > 
      <img alt="True" height="18" src="/images/true.png?1260575361" width="18" /><a href="/hosts/153/report">about 1 hour</a> 
    </td> 

Must be in the javascript somewhere causing it.


Related issues

Is duplicate of Foreman - Bug #142: RRD graph URL should not get forced to HTTPRejected2009-12-20

Associated revisions

Revision 27c73a6a (diff)
Added by Ewoud Kohl van Wijngaarden over 7 years ago

Be compliant with the Puppet Forge

This fixes #143, as reported by @ryanycoleman

The ~> dependency expression used here is not expressly supported by the
Puppet Forge and module tool. It may not always work as desired.

The currently supported expressions are documented here1.

[1]: http://docs.puppetlabs.com/puppet/latest/reference/modules_publishing.html#dependencies-in-the-modulefile

History

#1 Updated by Ohad Levy almost 12 years ago

  • Status changed from New to Closed

marked as duplicate of #142

#2 Updated by Karl Pietri almost 12 years ago

This bug is not a duplicate of #142. I made the suggested patch but the behavior still exists. Perhaps i wasn't clear enough. It seems like it is the active scaffold javascript that is hijacking the link and redirecting to http instead of https.

if you go to the hosts page for the list of hosts (or the out of sync/error pages) the last report column has a proper url but when you click on it you get taken to http:// instead.

Also available in: Atom PDF