Project

General

Profile

Actions

Feature #147

closed

Display class selection for hosts based on environments

Added by Josh Baird over 14 years ago. Updated about 14 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

When adding a new host, the list of classes that Foreman gives you should only be for the particular environment that you would like to place this host in. When two environments contain classes with the same names, you are unable to differentiate between the classes/environments.

I think one way of doing this is to first ask the user to select the environment, and then based on the user's selection, display the list of classes in that environment. This function should also support a "common" modulepath for classes that are common to multiple modules. I define this in my puppet.conf like:

[fcdev]
manifest = /etc/puppet/manifests/fcdev/manifests/site.pp
modulepath = /etc/puppet/manifests/fcdev/modules:/etc/puppet/manifests/common/modules
pluginsync = false


Related issues 2 (0 open2 closed)

Related to Foreman - Feature #66: Add Logic to host edit pageClosedPaul Kelly11/05/2009Actions
Is duplicate of Foreman - Refactor #193: move hosts controller away from ASClosedOhad Levy03/25/2010Actions
Actions #1

Updated by Ohad Levy over 14 years ago

  • Category set to Web Interface
  • Assignee set to Ohad Levy
  • Target version set to 0.1-4
Actions #2

Updated by Ohad Levy over 14 years ago

  • Target version changed from 0.1-4 to 0.1-5

This would be really easy once we get rid of ActiveScaffold, which is target to 0.1-5

Actions #3

Updated by Ohad Levy about 14 years ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF