Project

General

Profile

Bug #14783

Operating system description length accepts more than 255 characters

Added by Daniel Lobato Garcia over 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1328935
Description of problem:
Operating system description length accepts more than 255 characters

Version-Release number of selected component (if applicable):
satellite-6.2.0-8.2.beta.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1.Create an operating system with description of length 256 characters
2.
3.

Actual results:
Operating system created with no errors

Expected results:
Until last build, we allowed os description length upto a maximum of 255 characters only, now its broken.

Additional info:


Related issues

Related to Foreman - Bug #9357: Not all description fields Foreman are the same length. Some are text fields and some are strings (255 chars)Closed2015-02-12

Associated revisions

Revision 86500467 (diff)
Added by Daniel Lobato Garcia about 4 years ago

Fixes #14783 - Limit OS description to 255

This field forms part of 'os.title' too.

History

#1 Updated by Dominic Cleal over 4 years ago

  • Related to Bug #9357: Not all description fields Foreman are the same length. Some are text fields and some are strings (255 chars) added

#2 Updated by Dominic Cleal over 4 years ago

  • Status changed from New to Rejected

This isn't a bug, it's by design: #9357.

#3 Updated by David Davis over 4 years ago

I would argue that this probably should be a bug. The description is used as an identifier in the UI and the field is even a textfield and not a text area. I think we should either change description back to a varchar in the database or reinstate a limit to OS description. Unlimited is too long for operatingsystems index, architecture edit, etc.

#4 Updated by David Davis over 4 years ago

  • Assignee changed from Ivan Necas to David Davis

#5 Updated by Dominic Cleal over 4 years ago

  • Category set to Web Interface
  • Status changed from Rejected to Ready For Testing
  • Assignee changed from David Davis to Daniel Lobato Garcia
  • Pull request https://github.com/theforeman/foreman/pull/3455 added

#6 Updated by Marek Hulán about 4 years ago

  • Legacy Backlogs Release (now unused) set to 160

#7 Updated by Daniel Lobato Garcia about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF