Project

General

Profile

Bug #1483

Edit Hosts privilege not working

Added by Roger Spencer over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Category:
Authorization
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Granting a user "Edit Hosts" privileges does not work. Any attempt to edit a host fails. Only when "Create hosts" is granted is the user able to edit hosts. Of course, now they can create new hosts which is undesirable.

Currently seen in version 0.4.2.

History

#1 Updated by Roger Spencer over 7 years ago

Should note the privilege made by creating a new role and adding view_hosts and edit_hosts permissions to it. User is then placed in that role.

#2 Updated by Ohad Levy over 7 years ago

  • Assignee set to Greg Sutcliffe

Hi Greg,

Mind having a look if you have time?
10x

#3 Updated by Greg Sutcliffe over 7 years ago

Confirmed on 0.4.2. However, on my permissions branch, this is already fixed, since I refactored how hosts get edited anyway :)

Fixed in 3aa520f441 awaiting merge.

#4 Updated by Greg Sutcliffe over 7 years ago

  • Target version set to 1.0
  • % Done changed from 0 to 100

#5 Updated by Greg Sutcliffe over 7 years ago

  • Status changed from New to Closed

Also available in: Atom PDF