Project

General

Profile

Bug #15176

Bundler fails to find compatible fog-google version

Added by Dominic Cleal almost 6 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Packaging
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

The older version of Bundler (1.3.5) used on Ubuntu 14.04 is failing to find a compatible version of fog-google due to the two slightly different requirements in bundler.d/gce.rb and fog's gemspec:

08:38:16 /usr/bin/ruby2.0 /usr/bin/bundle pack --all
08:38:18 Fetching gem metadata from https://rubygems.org/........
08:38:31 Fetching gem metadata from https://rubygems.org/..
08:38:32 Resolving dependencies................
08:38:33 Bundler could not find compatible versions for gem "fog-google":
08:38:33   In Gemfile:
08:38:33     fog (= 1.38.0) ruby depends on
08:38:33       fog-google (<= 0.1.0) ruby
08:38:33 
08:38:33     fog-google (0.3.2)

The bundler.d/gce.rb specification should just mirror fog's for now for consistency. When fog changes it and we update fog, bundler.d/gce.rb can be updated in sync.


Related issues

Related to Foreman - Refactor #8884: Drop Ruby 1.9.3 supportClosed2015-01-09

Associated revisions

Revision 9d3925e1 (diff)
Added by Dominic Cleal almost 6 years ago

fixes #15176 - match fog's pin of fog-google

History

#1 Updated by Dominic Cleal almost 6 years ago

#2 Updated by Dominic Cleal almost 6 years ago

  • Description updated (diff)

#3 Updated by Dominic Cleal almost 6 years ago

  • Description updated (diff)

#4 Updated by The Foreman Bot almost 6 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3551 added

#5 Updated by Dominic Cleal almost 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF