Project

General

Profile

Bug #15824

Enabling a repository needs to fail on pulp error

Added by Brad Buckingham over 2 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1335898
Description of problem:

A repository can be enabled even if there is an error in pulp.
Version-Release number of selected component (if applicable):
How reproducible:
%100
Steps to Reproduce:
1. Turn off a repo in pulp
2. Try to enable this repo
or
1. Don't install ostree
2. Try to enable an ostree repo
Actual results:
you should see a pulp error in /var/log/messages but the repo will be available in the Products page.
Expected results:
The repo is not able to be enabled and an appropriate message is returned to the user when enabling it errors in pulp.
Additional info:
This is related to how we handle the task in dynflow. We should be enabling the repo in pulp first before we add it to the the database.

Related issues

Has duplicate Katello - Bug #15516: enabling an ostree repository causes error on manifest refresh actionsDuplicate2016-06-24
Blocks Katello - Tracker #15825: Sprint 1 : Content-FocusedNew2016-07-24

Associated revisions

Revision 236caa38 (diff)
Added by John Mitsch over 2 years ago

Fixes #15824 - enabling a repository should fail on pulp error (#6207)

When enabling a repository, if there is a pulp error, the task will
be paused after creating the repository in the database, though
it is not created in pulp (since it errored). Moving this to create
in plan phase of Katello::Repository::Create ensures that the task
will stop and not complete on a pulp error, leaving the repository
disabled.

History

#1 Updated by Brad Buckingham over 2 years ago

#2 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6207 added

#3 Updated by Justin Sherrill over 2 years ago

  • Subject changed from Enabling a repository needs to fail on pulp error to Enabling a repository needs to fail on pulp error
  • Legacy Backlogs Release (now unused) set to 162
  • Difficulty set to easy

#4 Updated by John Mitsch over 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Justin Sherrill over 2 years ago

  • Has duplicate Bug #15516: enabling an ostree repository causes error on manifest refresh actions added

Also available in: Atom PDF