Project

General

Profile

Bug #16049

Canceling repo sync broke my repo

Added by Leah Fisher almost 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

System running Foreman 1.11.3 and Katello 3.0.2

Hit the cancel button on my sync of Fedora OS repo. Was cancelled during the copying files (save_tar) part of the publish of the repo sync. The task entered a paused state so I resumed the task.

I then uploaded a package into the repo and that task completed successfully.
I then tried to publish the content view that this repo is in and got errors during the distributor publish tasks:
I got failures during the first distributor publish where it could not find rpms in the var/lib/pulp/published/yum/master/yum_distributor/Default_Organization-Fedora_23-os_x86_64/14563445.08/ directory. A bunch of No such file errors. Since this threw the error, I skipped this task when the task was paused. I also got an error on the second distributor_publish where it Couldn't find a published directory for the repo. I skipped that task as well and the publish completed.

Next, I went to sync the repo, figuring it would fix all the issues, but it had the same error during sync could not find rpms in the var/lib/pulp/published/yum/master/yum_distributor/Default_Organization-Fedora_23-os_x86_64/14563445.08/ directory. A bunch of No such file errors.

History

#1 Updated by Justin Sherrill almost 6 years ago

  • Category set to 91
  • Difficulty set to medium

#2 Updated by Justin Sherrill almost 6 years ago

  • Assignee set to Chris Roberts

#3 Updated by Chris Roberts over 5 years ago

  • Status changed from New to Assigned

Starting to work on this.

#4 Updated by Chris Roberts over 5 years ago

  • Status changed from Assigned to Need more information

Hi Leah,

Did you happen to have a foreman-debug from the system when this happened?

- Chris Roberts

#5 Updated by Chris Roberts over 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Hi Leah,

Have you hit the issue again, I tried to reproduce here and was not able to hit this.

- Chris

#6 Updated by Justin Sherrill over 5 years ago

  • Status changed from Need more information to Rejected

Hello, we're going ahead and closing this as we were not able to reproduce. If you can figure out an easier way to reproduce please let us know!

Thanks

Also available in: Atom PDF