Project

General

Profile

Bug #17780

Can't specify organization in hammer content-view/repository delete/update commands

Added by Andrew Kofink over 2 years ago. Updated 11 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Content Views
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1398677
++ This bug was initially created as a clone of Bug #1388642 ++

Description of problem:
Following content-view filter commands are missing --organization, --organization-id and --organization-label options:
content-view filter delete
content-view filter info
content-view filter list
content-view filter update
This becomes and issue when you don't have `content-view` and `content-view filter` IDs and specifying them by names, in such case organization should be specified too, e.g.:
content-view filter delete --organization="test_org" --name="test_filter" --content-view="test_cv"
Currently this command returns following error:
Error: Unrecognised option '--organization'
However, if you attempt to pass the command with no organization specified, you'll receive following error:
Could not delete the filter:
Error: Could not find organization. Some search options were missing, please see --help.
Version-Release number of selected component (if applicable):
Satellite 6.3 Snap 5
How reproducible:
Always
Steps to Reproduce:
1. See `Description of problem`
2.
3.
Actual results:
--organization, --organization-id and --organization-label options are missing, no way to execute commands with only names (not ids) specified
Expected results:
--organization, --organization-id and --organization-label options should be accepted
Additional info:
--- Additional comment from RHEL Product and Program Management on 2016-10-25 16:26:36 EDT ---
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases,
it is also being identified as a blocker for this release.
Please resolve ASAP.
--- Additional comment from RHEL Product and Program Management on 2016-10-25 16:45:20 EDT ---
Since this issue was entered in Red Hat Bugzilla, the pm_ack has been
set to + automatically for the next planned release
--- Additional comment from Marek Hulan on 2016-10-27 06:33:11 EDT ---
I don't think this is a blocker, it should work fine through UI. Anyway fix is in upstream so should lad in downstream soon.
--- Additional comment from RHEL Product and Program Management on 2016-10-27 06:36:25 EDT ---
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases,
it is also being identified as a blocker for this release.
Please resolve ASAP.
--- Additional comment from Roman Plevka on 2016-11-25 08:43:05 EST ---
`hammer content-view delete` is affected by this as well

Related issues

Is duplicate of Katello - Bug #16794: hammer content-view filter list is missing --organization parameterClosed2016-10-04

History

#1 Updated by Justin Sherrill over 2 years ago

  • Subject changed from Can't specify organization in hammer content-view/repository delete/update commands to Can't specify organization in hammer content-view/repository delete/update commands
  • Category set to Content Views
  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by Andrew Kofink over 2 years ago

  • Is duplicate of Bug #16794: hammer content-view filter list is missing --organization parameter added

#3 Updated by Andrew Kofink over 2 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF