Project

General

Profile

Bug #20763

"Create SSH key" GUI button incorrectly named

Added by Sebastian Gräßl about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1480248

Description of problem:

"Create SSH key" button should be renamed to "Add SSH key". It does not make sense for the button to be named "Create SSH key" the user is not generating a new SSH key but instead adding an existing one that is on their system. The UI has no way of creating an SSH key. As the button is currently described, it is misleading for the user.

How reproducible:
Always

Steps to Reproduce:
In the Web UI, navigate to Administer > Users. Select a user, for instance Admin. Select SSH keys in the tabbed pane. The button reads "Create SSH Key".

Actual results:
"Create SSH Key" button.

Expected results:
"Add SSH Key" button.

Associated revisions

Revision 00183e17 (diff)
Added by Sebastian Gräßl about 3 years ago

Fixes #20763 - Reword "Create SSH key" to "Add SSH key"

History

#1 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4791 added

#2 Updated by Timo Goebel about 3 years ago

  • Subject changed from "Create SSH key" GUI button incorrectly named to "Create SSH key" GUI button incorrectly named
  • Legacy Backlogs Release (now unused) set to 240

#3 Updated by Anonymous about 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Marek Hulán about 3 years ago

  • Assignee set to Sebastian Gräßl
  • Target version set to 214

Timo did you intended to ask for cherry-picking this to 1.16-stable? Since we're after the 1.16 branching point, all new stuff automatically goes to 1.17.0

#5 Updated by Daniel Lobato Garcia about 3 years ago

  • Legacy Backlogs Release (now unused) changed from 240 to 296

Setting to 1.17 tentatively until Timo reponds

Also available in: Atom PDF