Project

General

Profile

Bug #2167

Welcome page should link to manual instead of wiki

Added by Dominic Cleal almost 10 years ago. Updated about 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

The welcome page shown when no data exists should link to the new manual on theforeman.org instead of the wiki pages. Perhaps via some static redirects for a given version number, as the URLs may not be consistent.


Related issues

Is duplicate of Foreman - Feature #2763: Wiki links should be replaced with correct doco linksClosed2013-07-09

History

#1 Updated by Ky Zh over 9 years ago

I will try to send a new PR to update the few links within foreman.

#2 Updated by Ohad Levy over 9 years ago

  • Assignee deleted (Ohad Levy)

Ky Zh - thanks!

#3 Updated by Dominic Cleal over 9 years ago

Ky Zh wrote:

I will try to send a new PR to update the few links within foreman.

Thanks! FYI, the manual URL will be versioned for 1.2, so best to make the URLs in the app point to this. We're about to push the 1.2 manual to the website (as a copy of 1.1).

#4 Updated by Ohad Levy over 9 years ago

Dominic - there is a latest redirect, but maybe we can actually link to the correct version (as foreman knows the version too;))

#5 Updated by Dominic Cleal over 9 years ago

Yep, it should match the version rather than latest ideally.

#6 Updated by Ky Zh over 9 years ago

So i went ahead and did a PR https://github.com/theforeman/foreman/pull/571
One fix the home page, one fix the other link related to the wiki.

I can change 1.1 occurrences to 1.2 and do another pull request ?

A solution that could work for the front page would be to have http://www.theforeman.org/manuals or http://www.theforeman.org/manuals/ redirecting to the latest version available.
Another one would be to replace the "1.1" strings by the foreman version.
I don't know how complicated the later would be to do.

#7 Updated by Ky Zh over 9 years ago

Just realised i missed the last two comments.
I will try to figure where the version is hold and what need to change to make it available to the template.

#8 Updated by Dominic Cleal over 9 years ago

  • Status changed from New to Ready For Testing

Thanks, I'll review your PR soon.

You can use latest in place of 1.1/1.2, but it won't work well as we will want to move links around. We do have SETTINGS[:version] for getting the current version (which is 1.1 in develop, even though it will be 1.2), so that would be a good solution.

EDIT: just push with -f to update your existing branch rather than a new PR

#9 Updated by Dominic Cleal over 9 years ago

  • Target version deleted (1.2.0)

#10 Updated by Dominic Cleal about 9 years ago

  • Is duplicate of Feature #2763: Wiki links should be replaced with correct doco links added

#11 Updated by Dominic Cleal about 9 years ago

  • Status changed from Ready For Testing to Duplicate

Also available in: Atom PDF