Project

General

Profile

Support #22284

Unable to parse /usr/lib/ruby/bin/json_inventory.sh as an inventory

Added by Romans Krjukovs over 4 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

Hi,

I'm trying to run Ansible role's playbooks from Foreman.
Got following in the output after pressing "Play Ansible" button:

[WARNING]: Unable to parse /usr/lib/ruby/bin/json_inventory.sh as an inventory
source

In the DynFlow console i can see that inventory data with proper information
about host is passed:

Anyone know what i'm missing here?
How /usr/lib/ruby/bin/json_inventory.sh is created ? (there is no such file and path on the host currently).
Should that file exists there and is it static or created dynamically by foreman ?
Or is it just a wrong setting somewhere and that's the reason why correct inventory data passed on input is not used ?

Thank You!

Regards
/Romans

pic11.jpg View pic11.jpg 66.5 KB Romans Krjukovs, 01/16/2018 12:52 PM
pic2.jpg View pic2.jpg 369 KB Romans Krjukovs, 01/16/2018 12:56 PM
Pic11 Pic2

History

#1 Updated by Dirk Götz over 4 years ago

I also hit this bug on Debian with Foreman 1.16.0 and Ansible Plugin 1.4.6.

I found the inventory script located in /usr/bin/, so I created a symbolic link from /usr/lib/ruby/bin/ to it. Afterwards I got a Permission denied which was caused by .ansible directory not existing in ~foreman-proxy and the user being not allowed to create it. With the directory existing it failed because of strict host key checking and password authentication, which I solved by creating a ssh config disabling the host key checking.

#2 Updated by Daniel Lobato Garcia over 4 years ago

Romans, are you also finding this bug in Debian/Ubuntu?

#3 Updated by Joshua Doll over 3 years ago

Daniel Lobato Garcia wrote:

Romans, are you also finding this bug in Debian/Ubuntu?

I'm seeing this issue as well on Ubuntu 16.04. The json_inventory.sh script is installed to, /usr/bin instead of /usr/lib/ruby/bin/

#4 Updated by Ondřej Ezr over 1 year ago

Closing this, as it is too old and we failed to reproduce this.
Feel free to reopen this if you are still facing this issue.

#5 Updated by Ondřej Ezr over 1 year ago

  • Status changed from New to Resolved

Also available in: Atom PDF