Project

General

Profile

Bug #24749

hammer content-view version info does not require mandatory organization

Added by Chris Roberts 12 months ago. Updated 19 days ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Hammer
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
The API of content-view version info (called from hammer) does not require the mandatory organization.
This results in wrong behaviour:
- Specifying incorrect version is specified then an incorrect error because the filter is missing the organization.
- Specifying a version that is also in an other content view version available it returns error that more than one found

Without organization
-----------------------------------------------
[crash/LI] root@li-lc-1578:~# sudo -u hoici hammer -c /opt/hoici/etc/sat6/hammer-hoici.yaml content-view version info --content-view sat-6.3-ci --version 999
Error: one of content_view_versions not found

[crash/LI] root@li-lc-1578:~# sudo -u hoici hammer -c /opt/hoici/etc/sat6/hammer-hoici.yaml content-view version info --content-view sat-6.3-ci --version 2
Error: found more than one content_view_version

  1. Now (with luck) a version that is unique for all CVV returns the data:
    crash/LI] root@li-lc-1578:~# sudo u hoici hammer -c /opt/hoici/etc/sat6/hammer-hoici.yaml content-view version info --content-view sat-6.3-ci --version 19 | grep '^[^ ]'
    ID: 1244
    Name: hgp-crash:sat-6.3-ci 19.0
    Version: 19.0
    Description:
    Content View ID: 126
    Content View Name: hgp-crash:sat-6.3-ci
    Content View Label: hgp-crash_sat-6_3-ci
    Lifecycle Environments:
    Repositories:
    Puppet Modules:
    ----------------------------------------------

Now adding the correct Organization:
-----------------------------------------------
[crash/LI] root@li-lc-1578:~# sudo -u hoici hammer -c /opt/hoici/etc/sat6/hammer-hoici.yaml content-view version info --content-view sat-6.3-ci --version 999 --organization Hilti
Error: content_view not found

[crash/LI] root@li-lc-1578:~# sudo u hoici hammer -c /opt/hoici/etc/sat6/hammer-hoici.yaml content-view version info --content-view sat-6.3-ci --version 2 --organization Hilti
Error: content_view not found
----------------------------------------------

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. See calls in description
2.
3.

Actual results:
Unexpected results or incorrect errors

Expected results:
Correct results and errors

History

#1 Updated by The Foreman Bot 12 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7661 added

#2 Updated by Justin Sherrill 12 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.9.0
  • Status changed from Ready For Testing to Assigned
  • Category changed from API to Hammer
  • Subject changed from API content-view version info does not require mandatory organization to hammer content-view version info does not require mandatory organization
  • Pull request deleted (https://github.com/Katello/katello/pull/7661)

#3 Updated by Zach Huntington-Meath 10 months ago

  • Target version changed from Katello 3.9.0 to Katello 3.10.0

#4 Updated by Christine Fouant 9 months ago

  • Target version changed from Katello 3.10.0 to Katello 3.11.0

#5 Updated by Jonathon Turel 7 months ago

  • Target version changed from Katello 3.11.0 to Katello 3.12.0

#6 Updated by Chris Roberts 4 months ago

  • Target version changed from Katello 3.12.0 to Katello Backlog

#7 Updated by Chris Roberts 19 days ago

  • Status changed from Assigned to Rejected

Closing since downstream BZ is closed

Also available in: Atom PDF