Project

General

Profile

Feature #26413

A command that would show server version

Added by Ondřej Pražák over 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

It is possible to find out what version of Foreman we are running on the login screen or on the 'About' page, but it is not possible with hammer. There is /katello/api/status endpoint that exposes that information, maybe we could have `hammer status` command to show all the information that is exposed in this endpoint or just display version with `hammer version`.

Expected results:

Having hammer command that would show server version.


Related issues

Is duplicate of Hammer CLI - Feature #12587: Hammer Server version CommandClosed

History

#1 Updated by Oleh Fedorenko over 3 years ago

#2 Updated by Oleh Fedorenko over 3 years ago

  • Subject changed from A command that would show server version to A command that would show server version

There is a PR https://github.com/theforeman/hammer-cli-foreman/pull/394 which adds `hammer status` command showing, besides other things, server version.

#3 Updated by Oleh Fedorenko almost 3 years ago

  • Status changed from New to Closed

Also available in: Atom PDF