Project

General

Profile

Bug #28087

Token does not expire on logout

Added by Nikhil Kathole over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Authentication
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Since we use `reset_oidc_session` method now, there is no way that the session will be able to logout of the Foreman.
The session only logout now when the token expires. We need to handle the logout for SSO mechanisms.

Steps:
1) Login via SSO
2) Try to logout.


Related issues

Related to Foreman - Feature #25809: Keycloak integration with ForemanClosed
Related to Foreman - Tracker #28345: SSO using OpenID ConnectNew

History

#1 Updated by Marek Hulán over 1 year ago

#2 Updated by Rahul Bajaj over 1 year ago

#3 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7245 added

#4 Updated by Tomer Brisker over 1 year ago

  • Status changed from Ready For Testing to New
  • Pull request deleted (https://github.com/theforeman/foreman/pull/7245)

#5 Updated by Rahul Bajaj over 1 year ago

  • Status changed from New to Closed

Since we are looking at an SSO functionality, the token will only expire on session expiration. Again this will be considered as NOT A BUG. Closing this issue for now, feel free to open if you fell otherwise.

Also available in: Atom PDF