Project

General

Profile

Bug #28181

undefined local variable or method `unit_ids' when uploading DEB content to a repo

Added by Evgeni Golov over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Content Uploads
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

After calling import_uploads on a DEB repo, the import task fails:

2019-11-01T12:40:28 [E|bac|] undefined local variable or method `unit_ids' for #<Actions::Katello::Repository::FilteredIndexContent:0x00007feb246282e0> (NameError)
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.13.1/app/lib/actions/katello/repository/filtered_index_content.rb:23:in `run'

This was fixed in master as part of https://projects.theforeman.org/issues/26240, but never backported to 3.13.z :(


Related issues

Is duplicate of Katello - Bug #28101: Fix deb uploads to a repoClosed

History

#1 Updated by Evgeni Golov over 2 years ago

  • Status changed from New to Duplicate

dupe of #28101

#2 Updated by Evgeni Golov over 2 years ago

  • Is duplicate of Bug #28101: Fix deb uploads to a repo added

#3 Updated by Justin Sherrill over 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello Recycle Bin

Also available in: Atom PDF