Project

General

Profile

Bug #28354

Pulp 3 Docker repo distribution collision for mirrors when changing environment naming scheme

Added by Ian Ballou 4 months ago. Updated 29 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

If you publish a Docker content view, sync it with a mirror, change the environment naming scheme, and the sync again, it'll fail with an error like this: https://paste.fedoraproject.org/paste/s6ekvDoQGtbUqx-F~VY2pQ

The issue is that, in refresh_distributions for in repository_mirror.rb, we look up the current distributions by their path, when we should be looking them up by their path and their name.

History

#1 Updated by Ian Ballou 4 months ago

Changing the if statement in refresh_distributions to

if (distro = repo_service.lookup_distributions(base_path: path).first) ||
   (distro = repo_service.lookup_distributions(name: "#{backend_object_name}").first)

should fix it.

#2 Updated by Ian Ballou 4 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8429 added

#3 Updated by Samir Jha 4 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.15.0

#4 Updated by Ian Ballou 4 months ago

  • Status changed from Ready For Testing to Closed
  • Fixed in Releases Katello 3.15.0 added

#5 Updated by Jonathon Turel 29 days ago

  • Category set to Repositories

Also available in: Atom PDF