Project

General

Profile

Bug #31522

CentOS Kickstart stopped working after weekly sync.

Added by Hil Palmer over 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Content Views
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hello,

We have an issue where we will need to update our ISO to match the latest kickstart from CentOS again. Seems like even though we have our CentOS 8.2 Kickstart Repository locked into a Content View, the backend repository gets updated and the kernel version changes. So when we boot from our 8.2 ISO (or PXE boot) and when it attempts to connect to the CentOS 8.2 Kickstart repo on the foreman server it will not allow anaconda to fully boot.

So for a quick example that I am seeing... I sync'd my kickstart repository from http://mirror.centos.org/centos/8.2.2004/BaseOS/x86_64/kickstart. If you look at the files within http://mirror.centos.org/centos/8.2.2004/BaseOS/x86_64/kickstart/images/pxeboot you will see the dates and sizes of the files that I expect. BUT now when we sync'd the standard repository for CentOS which is now 8.3 from http://mirror.centos.org/centos/8/BaseOS/x86_64/os into a different repo and content view... We are getting the file size and dates within our CentOS 8.2 Kickstart Content View found within http://mirror.centos.org/centos/8/BaseOS/x86_64/os/images/pxeboot.

Thanks,
Hil

Kickstart Repo - CentOS 8.2.png View Kickstart Repo - CentOS 8.2.png 186 KB Hil Palmer, 12/17/2020 03:22 PM
Update Repo - CentOS 8.png View Update Repo - CentOS 8.png 184 KB Hil Palmer, 12/17/2020 03:22 PM
Kickstart%20repo%20 %20centos%208.2 Update%20repo%20 %20centos%208

History

#1 Updated by Lukas Zapletal over 1 year ago

  • Status changed from New to Need more information

Hello,

it appears you accidentally added 8 as 8.3. Compare the difference:

These are two very different repositories! Typically you want to synchronize both, the 8.y is used for provisioning (kickstart tree, PXE files) while 8 is used to update your systems from. Do not use 8 to kickstart because this tree changes over time and also PXE files gets regenerated which can cause issues on TFTP proxy (we use wget -c to download files and that can cause problems - this is a bug we want to fix).

Correct your upstream URLs and synchronize again. If you still see a difference and some files don't get synchronized then let's move this issue to Katello project for further investigation.

#2 Updated by Hil Palmer over 1 year ago

I understand that.

I am currently using the kickstart from the 8.2.2004 repo.

I am using the 8 (latest version) for my system repo for patching. This is where the files were updated.

But it effected my packages in my 8.2.2004 kickstart repo. If I look at the file system the file link within my kickstart repo points to the same file in the distribution contents as the link in my patching repo. The date on the link is correct, but the actual file is the updated one.

#3 Updated by Lukas Zapletal over 1 year ago

  • Category set to Content Views
  • Project changed from Foreman to Katello

Ok moving to Katello plugin, this is related to content which I don't deeply understand. If you can, please indicate how to reproduce this.

#4 Updated by Hil Palmer over 1 year ago

I would assume to reproduce... Get the kickstart repo setup and synced. Even put it into a Content View. Then setup the update channel and then sync it.

Attached is what I have configured, plus what I am seeing on the console.

Thank you!

#5 Updated by Jonathon Turel over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.0.0

#6 Updated by James Jeffers about 1 year ago

  • Triaged changed from Yes to No
  • Status changed from Need more information to New

#7 Updated by James Jeffers about 1 year ago

  • Triaged changed from No to Yes

#8 Updated by James Jeffers about 1 year ago

Hill, can you retry with Katello 4.0? If you still experience this problem, comment here and we will triage for followup ASAP.

#9 Updated by James Jeffers about 1 year ago

  • Status changed from New to Need more information

#10 Updated by James Jeffers about 1 year ago

  • Target version changed from Katello 4.0.0 to Katello 4.1.0

#11 Updated by Jonathon Turel about 1 year ago

  • Target version changed from Katello 4.1.0 to Katello Recycle Bin
  • Status changed from Need more information to Rejected

Haven't heard back so we're assuming this is working on Katello 4.0+ - Let us know if that's not the case. Thanks for filing!

Also available in: Atom PDF