Project

General

Profile

Actions

Bug #32358

closed

Package dependency is wrong on Katello UI

Added by Justin Sherrill about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1904369

Description of problem:

For Example: tfm-rubygem-hammer_cli_foreman_tasks

If we check the dependency using rpm we see the below output.

rpm -q --requires tfm-rubygem-hammer_cli_foreman_tasks
config(tfm-rubygem-hammer_cli_foreman_tasks) = 0.0.14-1.el7sat
rh-ruby25-ruby(release)
rh-ruby25-ruby(rubygems)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
tfm-rubygem(hammer_cli_foreman) > 0.1.1
tfm-rubygem(hammer_cli_foreman) < 3.0.0
tfm-rubygem(powerbar) >= 1.0.11
tfm-rubygem(powerbar) < 3.0
tfm-runtime
rpmlib(PayloadIsXz) <= 5.2-1

For the same package, the UI shows a different result.

Content >> Packages >> Serach for 'tfm-rubygem-hammer_cli_foreman_tasks' >> Dependencies

rh-ruby25-ruby(release)
rh-ruby25-ruby(rubygems)
tfm-rubygem(hammer_cli_foreman) > 0.1.1
tfm-rubygem(hammer_cli_foreman) > 3.0.0 -----> This is showing diffrent in rpm output.
tfm-rubygem(powerbar) > 3.0 -----> This is showing diffrent in rpm output.
tfm-rubygem(powerbar) >= 1.0.11
tfm-runtime

Version-Release number of selected component (if applicable):
Satellite 6.7+

Actual results:

rpm -q --requires and dependency on satellite UI is showing different information.

Expected results:
rpm -q --requires and dependency on satellite UI should produce similar information.

Additional info:

Actions

Also available in: Atom PDF