Project

General

Profile

Bug #33244

Product last_sync is not always correct

Added by Samir Jha 9 months ago. Updated 6 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

This comes from here: https://community.theforeman.org/t/products-display-not-always-showing-latest-successful-sync-s/24843

While it doesn't always fetch the correct repository sync task to get the sync time from, in case the product has never been synced at all, it fetches the last task on the product from Audit and doesn't check if the task is actually a sync task.


Related issues

Is duplicate of Katello - Bug #33413: 'Sync overview' Widget in 'Dashboard' is not showing any dataClosed

History

#1 Updated by Chris Roberts 9 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.3.0

#2 Updated by Justin Sherrill 8 months ago

  • Is duplicate of Bug #33413: 'Sync overview' Widget in 'Dashboard' is not showing any data added

#3 Updated by Justin Sherrill 8 months ago

  • Status changed from New to Duplicate

Either #32798 or #33413 likely fixed this

#4 Updated by Chris Roberts 6 months ago

  • Target version changed from Katello 4.3.0 to Katello Recycle Bin

Also available in: Atom PDF