Project

General

Profile

Bug #3555

Many organization and architecture "add_*" sub-commands fail with error

Added by Dominic Cleal over 5 years ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Category:
Foreman commands (obsolete)
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
Even on using valid name/id parameters, hammer organization sub-commands:
add_environment, add_domain, add_subnet, add_user and more.
Also hammer architecture add_operatingsystem always fail.

Version-Release number of selected component (if applicable):
rubygem-hammer_cli_foreman-0.0.9-2.el6sat.noarch
rubygem-hammer_cli-0.0.8-2.el6sat.noarch
rubygem-foreman_api-0.1.7-3.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. organization create --name org1
2. environment create --name envOne
3. organization add_environment --name org1 --environment-id 3
4. organization add_environment --name org1 --environment envOne

Actual results:
Error: resource or action not defined

Expected results:
It should be executed successfully

(https://bugzilla.redhat.com/show_bug.cgi?id=1025544)

History

#1 Updated by Dominic Cleal over 5 years ago

  • Description updated (diff)

#2 Updated by Dmitri Dolguikh over 5 years ago

  • Target version set to 1.10.0

#3 Updated by Tomáš Strachota over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Tomáš Strachota

Seems to be fixed in the latest master. I'll release a new version and close as "fixed in version".

#4 Updated by Martin Bacovsky over 5 years ago

I believe this issue was fixed in foreman_api 0.1.8.
I can't reproduce it on my box. hammer_cli 0.0.9, hammer_cli_foreman 0.0.10, foreman_api 0.1.8

#5 Updated by Dominic Cleal over 5 years ago

  • % Done changed from 0 to 100
  • Legacy Backlogs Release (now unused) set to 2
  • Status changed from Assigned to Resolved

Thanks!

Also available in: Atom PDF