Project

General

Profile

Bug #4409

Submit button for Architecture creation doesn't close the form nor does it display the new architecture in the list

Added by Og Maciel over 8 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Using the web ui to create a new architecture I noticed that the submit button does not give any indication that the record was created (the architecture does get created)... you have to reload the page in order to see the new record. The form doesn't close either, which is confusing to the user. Clicking the Submit button again tells me the name I chose has already been taken but the record is not listed.

Steps:

  • Create a new architecture via the UI. Select a valid OS
  • Click the Submit button

The attached screenshot shows that the form is still open and that the new record is not listed in the list to the left of the UI.

Screen Shot 2014-02-20 at 5.56.35 PM.png View Screen Shot 2014-02-20 at 5.56.35 PM.png 63.4 KB Form is not closed after clicking Submit Og Maciel, 02/20/2014 10:57 PM
Screen Shot 2014-02-20 at 5.57.27 PM.png View Screen Shot 2014-02-20 at 5.57.27 PM.png 58.5 KB Name is already taken Og Maciel, 02/20/2014 10:58 PM
Screen%20shot%202014 02 20%20at%205.56.35%20pm Screen%20shot%202014 02 20%20at%205.57.27%20pm

Related issues

Related to Katello - Bug #4490: Roles UI page messes up after scrollingClosed2014-02-28

Associated revisions

Revision 63afa801 (diff)
Added by Brad Buckingham over 8 years ago

fixes #4409 - rename the id used for the content menu

For some reason, using 'content' as the id for the Content menu
was resulting in breakage in behavior for foreman's two-pane
implementation.

Without this change, the following would occur:
- User goes to a page, clicks 'New <object>' (e.g.
Architecture, Environment, User...)
- panel opens with form to allow user to enter
data for the object
- User clicks submit
- At this point, the form is submitted to the server
and the object is created; however, the form is never
closed and the list of objects is not updated.

Revision 3ec94f0c
Added by Brad Buckingham over 8 years ago

Merge pull request #3769 from bbuckingham/issue-4409

fixes #4409 - rename the id used for the content menu

History

#1 Updated by Ohad Levy over 8 years ago

  • Project changed from Foreman to Katello
  • Category deleted (Web Interface)

I can't reproduce it with Core foreman, just when Katello is installed.

Do you see any JS errors?

#2 Updated by Og Maciel over 8 years ago

I did not see any javascript errors. All requests and responses look normal.

#3 Updated by Mike McCune over 8 years ago

FYI, same thing happens for me with users and not just Architectures.

Try to create a user, hit Submit and nothing happens in the UI. If you refresh the Users list it shows the newly created user.

#4 Updated by Ohad Levy over 8 years ago

  • Related to Bug #4490: Roles UI page messes up after scrolling added

#5 Updated by Mike McCune over 8 years ago

  • Category set to Web UI
  • Assignee set to Brad Buckingham

#6 Updated by Brad Buckingham over 8 years ago

Made changes in Katello (https://github.com/Katello/katello/pull/3769) which allow the Foreman two-pane to work properly. It looks like the 'id' that Katello was using for the Content menu was interfering with Foreman. The id used was 'content'.

#7 Updated by Brad Buckingham over 8 years ago

It looks like the source of the conflict is that Foreman two-pane uses #content, which conflicted with the plugin using the same id in the menu.

E.g.
./two-pane.js:46: $('#content').html(response.responseText);
./two-pane.js:66: $('#content').html(response.responseText);
./two-pane.js:109: var form_content = $("#content form.well", response);
./two-pane.js:117: $('#content').replaceWith($("#content", response));

#8 Updated by Brad Buckingham over 8 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset katello|commit:63afa801936cff8db1c6b0db7310aaf75046e3ef.

#9 Updated by Eric Helms about 8 years ago

  • Triaged set to Yes

#10 Updated by Eric Helms almost 8 years ago

  • Legacy Backlogs Release (now unused) set to 13

Also available in: Atom PDF