Project

General

Profile

Bug #6714

Error message needs to be rephrased when we create media without passing name

Added by Dominic Cleal about 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Rails
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1121945
Description of problem:
when we create install media without name, UI raised following error:

can't be blank and can't be blank or contain trailing white spaces.

I think this message needs to be rephrased.
Reason:

1. error message includes "can't be blank" twice. So one entry "can't be blank" is sufficient.

2. user can create media with trailing spaces so the "or contain trailing white spaces" is also not valid.

Version-Release number of selected component (if applicable):
sat6 GA snap1

How reproducible:
always

Steps to Reproduce:
1. create media without passing media name
2.
3.

Actual results:
UI raised following error:

can't be blank and can't be blank or contain trailing white spaces

Expected results:
I think message needs to be rephrased to just: can't be blank

Additional info:
Processing by MediaController#create as */*
Parameters: {"utf8"=>"✓", "search"=>"", "authenticity_token"=>"VX+UKFuIgqWyHwxAdhnLIrzFLAmDgGh5qENjFuLnsso=", "medium"=>{"name"=>"", "path"=>"http://mirror.fakeos.org/vUABdE/$major.$minor/os/$arch", "media_path"=>"", "config_path"=>"", "image_path"=>"", "os_family"=>"", "location_ids"=>[""], "organization_ids"=>[""]}}
Failed to save: Name can't be blank, Name can't be blank or contain trailing white spaces.


Related issues

Is duplicate of Foreman - Bug #6432: attributes missing :presence => trueClosed2014-06-29

History

#1 Updated by Dominic Cleal about 5 years ago

  • Category set to Rails

#2 Updated by Tomer Brisker over 4 years ago

  • Status changed from New to Closed

fixed already in #6432.

#3 Updated by Dominic Cleal over 4 years ago

  • Is duplicate of Bug #6432: attributes missing :presence => true added

Also available in: Atom PDF