Project

General

Profile

Bug #7468

hammer cli does not list authorized type info for a user other than internal

Added by Dominic Cleal over 6 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Foreman commands (obsolete)
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1134482
Description of problem:

hammer user info, does not display the Authorized type other than "Internal"

Here,

admin: local user
tadmin: ldap user

[root@dhcp201-170 ~]# hammer user info --login admin
Id: 3
Login: admin
Name: Admin User
Email:
Admin: yes
Authorized by: Internal
Last login: 2014/08/27 13:11:27
Roles:
Anonymous
User groups:

Created at: 2014/08/25 20:02:06
Updated at: 2014/08/27 13:11:27

[root@dhcp201-170 ~]# hammer user info --login tadmin
Id: 6
Login: tadmin
Name: test admin
Email:
Admin: no
Authorized by:
Last login: 2014/08/27 13:11:57
Roles:
Anonymous
User groups:

Created at: 2014/08/27 13:11:56
Updated at: 2014/08/27 13:11:57

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
as seen from above, "authorized by": is blank.

Expected results:
hammer cli should provide "Authorized by": LDAP-dhcp201-136

when the command, 'hammer user info --login tadmin' is issued.

NOTE: tadmin here is ldap user.

Additional info:


Related issues

Related to Hammer CLI - Feature #2924: Add commands for managing LDAP auth sourcesClosed2013-08-13
Is duplicate of Foreman - Bug #14705: Trying to change internal password authentication to LDAP for all the users but unable to do from hammer CLI.Duplicate2016-04-19

Associated revisions

Revision 11a5f841 (diff)
Added by Stephen Benjamin almost 5 years ago

fixes #7468 - show auth source name for all auth sources

Revision 55e5d478
Added by Tomas Strachota almost 5 years ago

Merge pull request #222 from stbenjam/7468

fixes #7468 - show auth source name for all auth sources

History

#1 Updated by Dominic Cleal over 6 years ago

  • Subject changed from hammer cli does not provide authorized type info other than internal to hammer cli does not list authorized type info for a user other than internal
  • Category set to Foreman commands (obsolete)

#2 Updated by Dominic Cleal over 6 years ago

  • Related to Feature #2924: Add commands for managing LDAP auth sources added

#3 Updated by The Foreman Bot almost 5 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Stephen Benjamin
  • Pull request https://github.com/theforeman/hammer-cli-foreman/pull/222 added

#4 Updated by Stephen Benjamin almost 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Daniel Lobato Garcia about 4 years ago

  • Is duplicate of Bug #14705: Trying to change internal password authentication to LDAP for all the users but unable to do from hammer CLI. added

#6 Updated by Daniel Lobato Garcia about 4 years ago

  • Bugzilla link changed from 1134482 to 1312208

Also available in: Atom PDF