Project

General

Profile

Bug #7530

Speed up katello-installer --help

Added by Dominic Cleal about 7 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1142996 # time katello-installer --help
<snip>
real 1m27.999s
user 0m16.075s
sys 0m0.998s

System is a virtual machine with 12G ram and 4 CPUs. Rather modern hardware. Running --help on an installer should not take 1.5 minutes. Expected time would be <5 sec (tops).


Related issues

Is duplicate of Kafo - Feature #14447: Add serialised cache of parsed manifestsClosed2016-04-04

History

#1 Updated by Dominic Cleal about 7 years ago

I've personally never seen it that slow, but it certainly feels sluggish as the number of modules has increased. Perhaps it needs some build-time caching? (If the speed can't be improved any other way.)

#2 Updated by Marek Hulán about 7 years ago

we could possibly list manifests that contains information printed in help and keep their hashes and regenerate help only if they change

#3 Updated by Lukas Zapletal about 7 years ago

I think we can do similar what Apipie does - find the latest ctime on all the modules (there is no big benefit in fine-selecting only those relevant) and compare to the ctime of the cache file. This should be relatively fast (<1s the first run).

#4 Updated by Dominic Cleal over 5 years ago

  • Is duplicate of Feature #14447: Add serialised cache of parsed manifests added

#5 Updated by Dominic Cleal over 5 years ago

  • Status changed from New to Resolved

Likely that using #14447 would help.

Also available in: Atom PDF