Project

General

Profile

Bug #8047

VM creation with distributed switch fails: "A component of the virtual machine is not accessible on the host."

Added by Dominic Cleal over 5 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Compute resources - VMware
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Click on Hosts >> New Host >> Fill the details (Select Host Group: ****|Deploy on: VMWare|Puppet Environment: **|Select Capsule Settings)

  • Now on Network (Tab) >> Choose Domain & Subnet.
  • Operating System (Tab) >> Architecture >> Operating System >> Provisioning Method (Image Based) >> Choose the Image.
  • Virtual Machine (Tab) >> Adjust the memory if required, choose Cluster >> Folder >> Guest OS (64 Bit) >> Network
    Interfaces NIC Type (VMXNET3) >> Network (//Lan-dvPortGroup//) >> Storage SCSI Controller (LSI Logic Parallel) >> Data Store (**) >> Name '' >> Size '' >> Thin Provision.

So after entering all the details and clicking on submit we are getting error in vsphere client as well as in satellite web ui.

Actual results:
Provisioning is getting failed with the below error message.

Error on Satellite:
~~~~~~~~~~~~~~~~~~
Failed to create a compute "redacted" (VMWare) instance "redacted": CannotAccessVmComponent: A component of the virtual machine is not accessible on the host.

Error on VSphere Client:
~~~~~~~~~~~~~~~~~~~~~~~
A component of the virtual machine is not accessible on the host.

Expected results:
New Server has to be provisioned on VMWare.

Additional info:
We couldn't able to reproduce the reported issue in our test lab as we do not have a similar environment with "Distributed Switch" to check provisioning with distributed virtual port groups (Lan-dvPortGroup).

As per my observation during the remote session, it looks like a bug. Customer says when the vm is provisioned for first time, the vm is assigned to a different network adapter (not the one selected from the web-ui during provisioning). But when it is provisioned for the second time the above error pops-up.

But the above said behaviour has not happened during the remote session. Customer gets the above error in the 1st attempt itself.


Related issues

Related to Foreman - Bug #5483: Network label empty after cloning vware vm using image and distributed switch for networkClosed2014-04-29

History

#1 Updated by Dominic Cleal almost 5 years ago

  • Related to Bug #5483: Network label empty after cloning vware vm using image and distributed switch for network added

#2 Updated by Chris Roberts about 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Chris Roberts
  • Target version set to 157
  • Difficulty set to medium

#3 Updated by Chris Roberts about 3 years ago

  • Status changed from Assigned to Rejected

#4 Updated by Chris Roberts about 3 years ago

Tested in Foreman 13.1 and working correctly. Closing this out

Also available in: Atom PDF