Project

General

Profile

Bug #8506

foreman-release-scl RPM is not signed with GPG key

Added by David Goldsmith over 5 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Packaging
Target version:
-
Difficulty:
trivial
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Output snippet from puppet run when using the foreman/foreman module from GitHub:

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install foreman-release-scl' returned 1: Package rhscl-ruby193-epel-7-x86_64-1-2.noarch.rpm is not signed
Error: /Stage[main]/Foreman::Install::Repos::Extra/Package[foreman-release-scl]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install foreman-release-scl' returned 1: Package rhscl-ruby193-epel-7-x86_64-1-2.noarch.rpm is not signed

If I change the yumrepo::gpgcheck setting from 1 to 0 for the 'foreman' repo, then installation works. Or if I manually run "yum --nogpgcheck install foreman-release-scl", then I can run puppet and leave the gpgcheck enabled for the other RPMs in the repository.


Related issues

Is duplicate of Packaging - Bug #7897: rhscl-* packages unsignedClosed2014-10-10

History

#1 Updated by Dominic Cleal over 5 years ago

  • Is duplicate of Bug #7897: rhscl-* packages unsigned added

#2 Updated by Dominic Cleal over 5 years ago

  • Status changed from New to Duplicate

Thanks for the report, this was resolved via #7897 for Foreman 1.7. EL7 support is slightly incomplete on 1.6 because of this, I don't think there's a workaround unless you can install the package another way.

#3 Updated by Tomer Brisker over 1 year ago

  • Category changed from 21 to Packaging

Also available in: Atom PDF