Project

General

Profile

Bug #9011

Satellite 6.0 manifest cannot be refreshed after updating entitlements

Added by Partha Aji over 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1183114
Description of problem:

Satellite 6.0 manifest cannot be refreshed after updating entitlements

Version-Release number of selected component (if applicable): Satellite 6.0

How reproducible: Customer Satellite 6.0 is currently broken and issue is %100 repeatable

Steps to Reproduce:
1. Add entitlements to manifest via the Red Hat Customer Portal
2. From the Satellite GUI attempt to 'Refresh Manifest'

Actual results:
The manifest is not refreshed and an error message indicating it has failed is printed in the GUI.

Expected results:
The new manifest will be updated to reflect the recent changes made in the Red Hat Customer Portal to the manifest.

Additional info:

There are errors logged in '/var/log/foreman/production.log' when the 'Refresh Manifest' button is clicked in the Satellite GUI. The main error that caught my attention is:

DeleteRestrictionError: Cannot delete record because of dependent repositories

Full sosreport and foreman-debug are attached to the SFDC case that will be attached to this bug.


Related issues

Related to Katello - Refactor #9012: The manifest actions in dynflow ought to rely on other actions for deleting repos and products, etcNew2015-01-17
Related to Katello - Feature #9054: In the UI, provide indication of (and maybe a way to remove) orphaned Red Hat products (via dynflow)New2015-01-20

Associated revisions

Revision 90f0f8e1 (diff)
Added by David Davis over 4 years ago

Fixes #9011 - Skip deleting products during manifest actions

Revision 63fd3da6
Added by David Davis over 4 years ago

Merge pull request #4944 from daviddavis/9011

Fixes #9011 - Skip deleting products during manifest actions

History

#1 Updated by David Davis over 4 years ago

Here are the steps I used to reproduce:

1. Create a manifest. Add an entitlement.
2. Upload your manifest to Sat 6
3. Enable and sync some repos
4. Go back to your manifest in the portal and remove your entitlement.
5. Refresh your manifest.

#2 Updated by David Davis over 4 years ago

  • Related to Refactor #9012: The manifest actions in dynflow ought to rely on other actions for deleting repos and products, etc added

#3 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Target version set to 63
  • Pull request https://github.com/Katello/katello/pull/4944 added
  • Pull request deleted ()

#4 Updated by David Davis over 4 years ago

After talking with Justin and Partha, it seems like the best course is to skip product deletion for now and in the next katello release, provide indication of (and maybe a way to remove) orphaned products (via dynflow).

#5 Updated by David Davis over 4 years ago

  • Related to Feature #9054: In the UI, provide indication of (and maybe a way to remove) orphaned Red Hat products (via dynflow) added

#6 Updated by David Davis over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#7 Updated by Eric Helms over 4 years ago

  • Triaged changed from No to Yes

#8 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) set to 23

Also available in: Atom PDF