Project

General

Profile

Bug #9163

katello-installer failed on rhel7 with error: Could not enable postgresql: Execution of '/sbin/chkconfig --add postgresql' returned 1:

Added by Stephen Benjamin over 5 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1187014
Description of problem:
katello installer failed on rhel7 with:

Could not enable postgresql: Execution of '/sbin/chkconfig --add postgresql' returned 1:

Version-Release number of selected component (if applicable):
nightly on rhel7

  • candlepin-0.9.38-1.el7.noarch
  • candlepin-common-1.0.18-1.el7.noarch
  • candlepin-selinux-0.9.38-1.el7.noarch
  • candlepin-tomcat-0.9.38-1.el7.noarch
  • elasticsearch-0.90.10-7.el7.noarch
  • foreman-1.8.0-0.develop.201501281301gitf8a56f5.el7.noarch
  • foreman-compute-1.8.0-0.develop.201501281301gitf8a56f5.el7.noarch
  • foreman-gce-1.8.0-0.develop.201501281301gitf8a56f5.el7.noarch
  • foreman-libvirt-1.8.0-0.develop.201501281301gitf8a56f5.el7.noarch
  • foreman-ovirt-1.8.0-0.develop.201501281301gitf8a56f5.el7.noarch
  • foreman-postgresql-1.8.0-0.develop.201501281301gitf8a56f5.el7.noarch
  • foreman-proxy-1.8.0-0.develop.201501280951gite1bc928.el7.noarch
  • foreman-release-1.8.0-0.develop.201501281301gitf8a56f5.el7.noarch
  • foreman-selinux-1.8.0-0.develop.201412151103gite2863e4.el7.noarch
  • foreman-vmware-1.8.0-0.develop.201501281301gitf8a56f5.el7.noarch
  • katello-2.1.0-1.201411061509gitb0b8f43.el7.noarch
  • katello-certs-tools-2.0.1-1.el7.noarch
  • katello-default-ca-1.0-1.noarch
  • katello-installer-2.2.0-1.201501272021gitf707d62.el7.noarch
  • katello-installer-base-2.2.0-1.201501272021gitf707d62.el7.noarch
  • katello-repos-2.1.1-1.el7.noarch
  • katello-server-ca-1.0-1.noarch
  • openldap-2.4.39-3.el7.x86_64
  • pulp-docker-plugins-0.2.1-0.2.beta.el7.noarch
  • pulp-katello-0.3-3.el7.noarch
  • pulp-nodes-common-2.5.1-1.el7.noarch
  • pulp-nodes-parent-2.5.1-1.el7.noarch
  • pulp-puppet-plugins-2.5.1-1.el7.noarch
  • pulp-puppet-tools-2.5.1-1.el7.noarch
  • pulp-rpm-plugins-2.5.1-1.el7.noarch
  • pulp-selinux-2.5.1-1.el7.noarch
  • pulp-server-2.5.1-1.el7.noarch
  • python-ldap-2.4.6-6.el7.x86_64
  • ruby193-rubygem-ldap_fluff-0.3.3-1.el7.noarch
  • ruby193-rubygem-net-ldap-0.10.0-1.el7.noarch
  • ruby193-rubygem-runcible-1.3.0-1.el7.noarch
  • rubygem-hammer_cli-0.1.4-1.201501260908gitf44b8c5.el7.noarch
  • rubygem-hammer_cli_foreman-0.1.4-1.201501221305git706b057.el7.noarch
  • rubygem-hammer_cli_foreman_bootdisk-0.1.2-1.el7.noarch
  • rubygem-hammer_cli_foreman_tasks-0.0.3-2.201409091410git163c264.git.0.988ca80.el7.noarch
  • rubygem-hammer_cli_import-0.10.4-1.el7.noarch
  • rubygem-hammer_cli_katello-0.0.7-1.201501281312git793226f.git.0.7c94372.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. katello-installer
2.
3.

Actual results:

Expected results:
installer should succeed

Additional info:
installer logs on console
[ INFO 2015-01-29 02:24:41 verbose] Executing hooks in group post
Something went wrong! Check the log for ERROR-level output
The full log is at /var/log/katello-installer/katello-installer.log
[ INFO 2015-01-29 02:24:41 verbose] All hooks in group post finished
[ERROR 2015-01-29 02:24:41 verbose] Repeating errors encountered during run:
[ERROR 2015-01-29 02:24:41 verbose] Could not enable postgresql: Execution of '/sbin/chkconfig --add postgresql' returned 1: error reading information on service postgresql: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] /Stage[main]/Postgresql::Server::Service/Service[postgresqld]/enable: change from false to true failed: Could not enable postgresql: Execution of '/sbin/chkconfig --add postgresql' returned 1: error reading information on service postgresql: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] Could not enable mongod: Execution of '/sbin/chkconfig --add mongod' returned 1: error reading information on service mongod: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] /Stage[main]/Mongodb::Server::Service/Service[mongodb]/enable: change from false to true failed: Could not enable mongod: Execution of '/sbin/chkconfig --add mongod' returned 1: error reading information on service mongod: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] Could not enable puppet: Execution of '/sbin/chkconfig --add puppet' returned 1: error reading information on service puppet: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] /Stage[main]/Puppet::Agent::Service/Service[puppet]/enable: change from false to true failed: Could not enable puppet: Execution of '/sbin/chkconfig --add puppet' returned 1: error reading information on service puppet: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] Could not enable foreman-proxy: Execution of '/sbin/chkconfig --add foreman-proxy' returned 1: error reading information on service foreman-proxy: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] /Stage[main]/Foreman_proxy::Service/Service[foreman-proxy]/enable: change from false to true failed: Could not enable foreman-proxy: Execution of '/sbin/chkconfig --add foreman-proxy' returned 1: error reading information on service foreman-proxy: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] Could not enable qpidd: Execution of '/sbin/chkconfig --add qpidd' returned 1: error reading information on service qpidd: No such file or directory
[ERROR 2015-01-29 02:24:41 verbose] /Stage[main]/Qpid::Service/Service[qpidd]/enable: change from false to true failed: Could not enable qpidd: Execution of '/sbin/chkconfig --add qpidd' returned 1: error reading information on service qpidd: No such file or directory
[root@qe-foreman-rhel7 ~]#


Related issues

Is duplicate of Katello - Bug #8478: MongoDB fails to start with a RHEL 7 systemClosed2014-11-21
Is duplicate of Katello - Bug #9202: katello-installer should use systemd instead of chkconfig for all services on rhel7Duplicate2015-02-03

Associated revisions

Revision c9fa4cd9 (diff)
Added by Justin Sherrill over 5 years ago

fixes #9163 - create a 2nd service_wait provider for systemd

Revision 9bb5e319
Added by Justin Sherrill over 5 years ago

Merge pull request #7 from jlsherrill/9163

fixes #9163 - create a 2nd service_wait provider for systemd

Revision 046627bc (diff)
Added by Justin Sherrill over 5 years ago

refs #9204,#9163 - updating service_wait and certs

Revision d670e8bc
Added by Justin Sherrill over 5 years ago

Merge pull request #171 from jlsherrill/8999

refs #8999,#9204,#9163 - updating foreman, service_wait, puppet, certs modules

History

#1 Updated by Stephen Benjamin over 5 years ago

The service-wait provider inherits from Puppet's :redhat provider, which this commit
broke by adding 'chkconfig -add':

https://github.com/puppetlabs/puppet/commit/fdfbcc06101d8b7bb9112321952ecbb01ee773b6

For now, if you need to get a working install, downgrade puppet to 3.7.3.

#2 Updated by Dominic Cleal over 5 years ago

  • Project changed from Foreman to Katello
  • Category set to Installer
  • Triaged set to No

#3 Updated by Eric Helms over 5 years ago

  • Priority changed from Normal to High
  • Target version set to 66
  • Legacy Backlogs Release (now unused) set to 14
  • Triaged changed from No to Yes

#4 Updated by Bradley Corner over 5 years ago

To downgrade puppet I had to execute

yum downgrade puppet puppet-labs-release puppet-server

The issue comes back though when using the git katello-deploy method of installing. When I execute
cd {git-base}/katello-deploy
./setup.rb --version 2.0
it upgrades the puppet back to 3.7.4.
I was able to get around it by first downgrading puppet then commenting out line 219. However the installer is still broke.

#5 Updated by dustin tsang over 5 years ago

  • Is duplicate of Bug #8478: MongoDB fails to start with a RHEL 7 system added

#6 Updated by dustin tsang over 5 years ago

  • Status changed from New to Resolved

tested seems to be fixed by #8478.
installer: output https://gist.github.com/3dc986eb9ce41dc32dc8
(for katello-installer @ 0c126a368f2e37755aa0d2fada2c54f51ea33f09)

#7 Updated by dustin tsang over 5 years ago

  • Is duplicate of Bug #9202: katello-installer should use systemd instead of chkconfig for all services on rhel7 added

#8 Updated by The Foreman Bot over 5 years ago

  • Pull request https://github.com/Katello/katello-installer/pull/173 added
  • Pull request deleted ()

#9 Updated by Bradley Corner over 5 years ago

Was this fix back-ported to 2.0? I deleted my deploy-katello and re pulled the repository. ran ./setup.rb --version 2.0 and still get the same errors.

#10 Updated by Stephen Benjamin over 5 years ago

@Bradley - It's unlikely to be backported to 2.0 - 2.1 is due in a day or two with the fix in place.

#11 Updated by Eric Helms over 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF