Project

General

Profile

Bug #9591

Override puppet configuration on host level does not work if specified on host group

Added by Shimon Shtein over 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Host creation
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1193812
Description of problem:
When editing a host it's not possible to override puppet ca and puppetmaster if the hostgroup specifies these.

Version-Release number of selected component (if applicable):
6.0.7

How reproducible:
Every time

Steps to Reproduce:
1. Create a host group that specifies puppet ca and puppetmaster
2. Assign a host to that host group
3. Edit the host and try remove puppet ca and puppetmaster, click submit
4. The Puppet CA and puppetmaster values are back

Actual results:
The values are still set.

Expected results:
It should be possible to override these values on host level.

Additional info:
Assigning the host to another host group that does not specify puppet ca or puppetmaster works as expected.


Related issues

Related to Foreman - Bug #6369: Unable to create host without Puppet master when specified on host groupClosed2014-06-25
Related to Foreman - Bug #9532: Removing environment from a host in hostgroup that has environment silently picks hostgroup environmentResolved2015-02-24
Related to Foreman - Bug #11022: Using a hostgroup with realm makes realm stickyResolved2015-07-06
Related to Discovery - Bug #9784: Autoprovisioning via hostgroup does not populate all parameters via WebUI or APIClosed2015-03-16
Related to Foreman - Bug #11255: Cloning host with host group throws error: undefined method `[]' for nil:NilClassClosed2015-07-30
Related to Foreman - Bug #11437: "Can't modify frozen Array" error on frozen arrays in select listClosed2015-08-19
Related to Foreman - Bug #11665: mail subscriptions can't be removedClosed2015-09-02
Related to Foreman - Bug #12461: Compute profiles are not applied when inheritedClosed2015-11-12
Related to Foreman - Feature #12710: Revert value to the inherited one when the user presses the "inherit" buttonNew2015-12-06

Associated revisions

Revision 04cb74c0 (diff)
Added by Shimon Shtein about 4 years ago

Fixes #9591 - Added support for "inherit" state.

History

#1 Updated by Dominic Cleal over 4 years ago

  • Related to Bug #6369: Unable to create host without Puppet master when specified on host group added

#2 Updated by Dominic Cleal over 4 years ago

  • Category set to Host creation

#3 Updated by Dominic Cleal over 4 years ago

Looks like an incomplete fix in #6369, which only works on initial host creation, not editing.

#4 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2230 added
  • Pull request deleted ()

#5 Updated by Dominic Cleal about 4 years ago

  • Related to Bug #9532: Removing environment from a host in hostgroup that has environment silently picks hostgroup environment added

#6 Updated by Dominic Cleal about 4 years ago

  • Related to Bug #11022: Using a hostgroup with realm makes realm sticky added

#7 Updated by Lukas Zapletal about 4 years ago

  • Related to Bug #9784: Autoprovisioning via hostgroup does not populate all parameters via WebUI or API added

#8 Updated by Dominic Cleal about 4 years ago

  • Legacy Backlogs Release (now unused) set to 63

#9 Updated by Shimon Shtein about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#10 Updated by Dominic Cleal about 4 years ago

  • Related to Bug #11255: Cloning host with host group throws error: undefined method `[]' for nil:NilClass added

#11 Updated by Dominic Cleal about 4 years ago

  • Related to Bug #11437: "Can't modify frozen Array" error on frozen arrays in select list added

#12 Updated by Dominic Cleal almost 4 years ago

  • Related to Bug #11665: mail subscriptions can't be removed added

#13 Updated by Dominic Cleal almost 4 years ago

  • Related to Bug #12461: Compute profiles are not applied when inherited added

#14 Updated by Dominic Cleal over 3 years ago

  • Related to Feature #12710: Revert value to the inherited one when the user presses the "inherit" button added

Also available in: Atom PDF