Project

General

Profile

Bug #11921

Features in controller authentication are not loaded correctly if you modify them from plugins

Added by Marek Hulán almost 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Plugins-Engines
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

We use add_smart_proxy_filters helper to configure authentication for requests coming from proxy (usually facts/reports). We pass features of proxies that should be considered as authenticated but since it's on class definition level, it evaluates during load time. If we register new importers that adds new potential feature, they are not re-evaluated. We should use pass Procs and evaluate them during runtime if we need dynamic list.


Related issues

Related to Foreman - Feature #8484: Make SmartProxyAuth concern more useful to pluginsClosed2014-11-24

Associated revisions

Revision 1d0315e0 (diff)
Added by Marek Hulán almost 4 years ago

Fixes #11921 - load dynamic features during runtime

Revision 9a68383d (diff)
Added by Marek Hulán over 3 years ago

Fixes #11921 - load dynamic features during runtime

(cherry picked from commit 1d0315e0630f23ca6c794d456d076c00020df275)

History

#1 Updated by The Foreman Bot almost 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2752 added
  • Pull request deleted ()

#2 Updated by Marek Hulán almost 4 years ago

For reproducers: it happens in development env if something loads v2 hosts controller (e.g. foreman-tasks) because it includes some concern. Then when another plugin registers new fact importer (foreman_chef, or I suppose foreman_salt as well) you won't see it in #require_smart_proxy_or_login among features hence authentication fails.

#3 Updated by Marek Hulán almost 4 years ago

  • Related to Feature #8484: Make SmartProxyAuth concern more useful to plugins added

#4 Updated by Marek Hulán almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Dominic Cleal almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 104

Also available in: Atom PDF