Project

General

Profile

Refactor #14022

secret_key_base should be configured

Added by Dominic Cleal about 4 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Rails
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Rails 4.1 adds a secrets.yml file that should be configured with a secret_key_base per environment. This replaces the secret token initialiser. Deprecation warnings are currently being issued by Rails:

DEPRECATION WARNING: You didn't set `secret_key_base`. Read the upgrade documentation to learn more about this new config option. (called from validate_secret_key_config!

http://edgeguides.rubyonrails.org/upgrading_ruby_on_rails.html#config-secrets-yml has more info.

This will need some updates to packaging too, since we have scripts to generate the tokens and link the files into the right place post-installation.


Related issues

Related to Foreman - Feature #7230: Upgrade Ruby on Rails to 4.1Closed2014-08-22
Is duplicate of Foreman - Refactor #7570: set secret_key_base for rails 6.0 upgradeClosed

History

#1 Updated by Dominic Cleal about 4 years ago

#2 Updated by Brandon Weeks about 4 years ago

  • Blocks Refactor #7570: set secret_key_base for rails 6.0 upgrade added

#3 Updated by Dominic Cleal about 4 years ago

  • Blocks deleted (Refactor #7570: set secret_key_base for rails 6.0 upgrade)

#4 Updated by Dominic Cleal about 4 years ago

  • Is duplicate of Refactor #7570: set secret_key_base for rails 6.0 upgrade added

#5 Updated by Dominic Cleal about 4 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF