Project

General

Profile

Bug #14980

Unused_ip AJAX request fails: undefined method `from' for #<IPAM::Dhcp..>

Added by Lukas Zapletal about 5 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Category:
DHCP
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

It always returns 404, no exception reported. Regression.


Related issues

Related to Foreman - Bug #13772: The orchestration code uses SQL loggerClosed2016-02-17
Related to Foreman - Feature #14661: Support IPv6 SubnetsClosed2016-04-15

Associated revisions

Revision 6d3f957b (diff)
Added by Lukas Zapletal about 5 years ago

Fixes #14980 - fixed unused_ip API subnet param

History

#1 Updated by Lukas Zapletal about 5 years ago

#2 Updated by Lukas Zapletal about 5 years ago

Well hidden, the cause error is logged through sql (orchestration) logger which I turn off usually.

#3 Updated by Lukas Zapletal about 5 years ago

The error was:

2016-05-10T13:02:11 [sql] [W] Failed to fetch a free IP from our proxy: ERF12-8202 [ProxyAPI::ProxyException]: Unable to retrieve unused IP ([NoMethodError]: undefined method `from' for #<IPAM::Dhcp:0x00564a3b54f4a8>) for proxy https://lzapx.brq.redhat.com:8443/dhcp

#4 Updated by Lukas Zapletal about 5 years ago

  • Related to Bug #13772: The orchestration code uses SQL logger added

#5 Updated by The Foreman Bot about 5 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Lukas Zapletal
  • Pull request https://github.com/theforeman/foreman/pull/3511 added

#6 Updated by Dominic Cleal about 5 years ago

#7 Updated by Dominic Cleal about 5 years ago

#8 Updated by Dominic Cleal about 5 years ago

  • Subject changed from Unused_ip API is broken to Unused_ip AJAX request fails: undefined method `from' for #<IPAM::Dhcp..>
  • Category set to DHCP
  • Legacy Backlogs Release (now unused) set to 136

#9 Updated by Lukas Zapletal about 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF