Project

General

Profile

Bug #15008

foreman-installer fails on RHEL7 because of SCLo repository

Added by Marek Hulán over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
RPMs
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

After https://github.com/theforeman/puppet-foreman/pull/435 was merged, foreman-installer nightly fails on RHEL7 Server with errors like

# [ERROR 2016-05-11 07:31:35 verbose]  Execution of '/usr/bin/yum -d 0 -e 0 -y list foreman-postgresql' returned 1: One of the configured repositories failed (CentOS-7Server - SCLo rh),

I believe this happens because we ship upstream centos-release-scl package copy from upstream which defines the repository as

http://mirror.centos.org/centos/$releasever/sclo/$basearch/sclo/

The issue is with $releasever which in this case is 7Server hence we get 404 on http://mirror.centos.org/centos/7Server/sclo/x86_64/sclo/repodata/repomd.xml

I'm not sure what would be the best fix, maybe repackaging the centos-release-scl or adding exception for RHEL platform in puppet-foreman module


Related issues

Has duplicate Foreman - Bug #15147: Installer failedDuplicate2016-05-23

Associated revisions

Revision ee014c78 (diff)
Added by Dominic Cleal over 4 years ago

fixes #15008 - use new centos-release-scl with releasever hardcoded

History

#2 Updated by Dominic Cleal over 4 years ago

In the first instance, please try opening a ticket in the CentOS Buildsys project, they may be willing to create appropriate symlinks on the mirrors so the repos are usable for RHEL too.

There are also RHEL-specific builds of centos-release-scl at https://github.com/sclorg/centos-release-scl#how-to-install-sclo-packages-on-rhel-systems and in Copr, but that's an added complication because the package names are identical. If anything I'd prefer to rebuild it as you suggest.

#3 Updated by Marek Hulán over 4 years ago

I hope I created it at the right place - https://bugs.centos.org/view.php?id=10838

#4 Updated by Dominic Cleal over 4 years ago

  • Project changed from Installer to Packaging
  • Category set to RPMs
  • Status changed from New to Assigned
  • Assignee set to Dominic Cleal
  • Legacy Backlogs Release (now unused) set to 136

#5 Updated by Dominic Cleal over 4 years ago

  • Has duplicate Bug #15147: Installer failed added

#6 Updated by Dominic Cleal over 4 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

#7 Updated by Bryan Kearney over 4 years ago

  • Bugzilla link set to 1334939

Also available in: Atom PDF