Project

General

Profile

Bug #15216

Installer fails if Satellite hostname doesn't have a TLD at the end of the domain

Added by Bryan Kearney about 3 years ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1127307
Users with domains containing hyphens are unable to install Satellite 6, they get errors during installation:

[root@sat6 ~]# katello-installer
/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[sat6.test.example-domain]: Could not evaluate: 500 Internal Server Error
Installing Done [100%]

We need to determine why Satellite 6 can't be installed on systems with a domain including a hyphen and support this use case.

Steps to reproduce:

1) Setup a system who's domain name resolves to something with a hyphen:

sat6test.example-domain.com

2) Attempt to run katello-installer

3) note errors

History

#1 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/348 added

#2 Updated by Justin Sherrill about 3 years ago

  • Priority changed from High to Normal

#3 Updated by Justin Sherrill about 3 years ago

  • Legacy Backlogs Release (now unused) set to 114
  • Difficulty set to easy

#4 Updated by Stephen Benjamin about 3 years ago

  • Status changed from Ready For Testing to Rejected

The attached bugzilla was closed, so closing this. The underlying cause of the reported error is not clear, reopen if we determine the cause of this.

Also available in: Atom PDF