Project

General

Profile

Bug #17572

Katello/puppet-certs - Puppet language error during agent run (success during apply),

Added by Robert Mattson over 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
hard
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

We receive the following error [1] when executing puppet-certs with puppet agent.
We have submitted a bug to Puppet Labs to resolve this issue in puppet.

This bug is submitted to track progress of the resolution of this issue in the puppetlabs issue tracker.

https://tickets.puppetlabs.com/browse/PUP-6960

Try to only submit Comments/Submissions and analysis to the puppetlabs ticket to track progress in a single location. Where possible.

[1] - Error: Failed to apply catalog: Parameter ca failed on Ca[katello-server-ca]: Expected Ca resource at /etc/puppet/modules/certs/manifests/init.pp:167

Associated revisions

Revision 9e576464 (diff)
Added by Timo Goebel over 2 years ago

fixes #17572 - module works with master compile

History

#1 Updated by Dominic Cleal over 2 years ago

  • Project changed from Foreman to Katello

#2 Updated by eric sorenson over 2 years ago

Is the normal mode of operation for these modules to be used with puppet apply, and it's unusual for them to run in agent/master mode? That's the impression I got from the IRC conversation about this, but it'd be good to know more - the root cause seems very fundamental (json catalogs lose data type information, and it's up to the type to reconstitute it) so it's surprising to me that not many people have hit the problem.

#3 Updated by Daniel Lobato Garcia over 2 years ago

These modules are normally ran via foreman-installer, which in turn uses https://github.com/theforeman/kafo , which.. uses puppet apply. I'd expect to be able to use them in master/agent mode though. I'd need to look into the details and get a reproducing setup (from what I see on PUP-6960 it's not so hard to reproduce). We already do some checking on https://github.com/Katello/puppet-certs/blob/59857e16dccbeb6e9546179f1965560ccf9a674c/lib/puppet/type/certs_common.rb#L46

#4 Updated by Justin Sherrill over 2 years ago

  • Category set to Installer
  • Status changed from New to Assigned
  • Assignee set to Eric Helms

#5 Updated by Justin Sherrill over 2 years ago

  • Legacy Backlogs Release (now unused) set to 114
  • Difficulty set to hard

#6 Updated by Timo Goebel over 2 years ago

  • Pull request https://github.com/Katello/puppet-certs/pull/127 added

I opened a PR with a suggested workaround for this.

#7 Updated by Timo Goebel over 2 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF