Project

General

Profile

Bug #1786

Incorrect VCPU count in Virtual Machine properties

Added by Andy Taylor about 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Category:
Compute resources
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Using Foreman 1.0, if you create a VM via a libvirtd compute resource and set VCPU to higher than 1, the VCPU under the Virtual Machine tab incorrectly shows 1 VCPU. For example, if you create a VM with 4 VCPUs, Foreman creates the VM correctly, but VCPU only shows 1.

History

#1 Updated by Andy Taylor about 10 years ago

Additional note: when I say Foreman creates the VM correctly, I mean it creates the VM with the right amount of VCPUs.

#2 Updated by Romain Vrignaud almost 10 years ago

  • Category set to Compute resources
  • Target version set to 1.1

Still present on 1.0.1

#3 Updated by Greg Sutcliffe almost 10 years ago

  • Target version changed from 1.1 to Bug scrub

#4 Updated by Joshua Hoblitt almost 10 years ago

Present in foreman-1.0.1-1.el6.noarch

#5 Updated by Romain Vrignaud over 9 years ago

  • Assignee set to Romain Vrignaud

#6 Updated by Romain Vrignaud over 9 years ago

  • Status changed from New to Closed

This was an upstream (fog) bug.
It should be fixed with https://github.com/fog/fog/pull/1279 .
This will need fog 1.8 to be fixed

#7 Updated by Romain Vrignaud over 9 years ago

  • Target version changed from Bug scrub to 1.1

Also available in: Atom PDF