Project

General

Profile

Bug #18096

Clicking on refresh manifest twice should warn about errors

Added by Daniel Lobato Garcia over 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Subscriptions
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

If you click on refresh manifest once, it creates a task to refresh it. This normally takes a long time. If you click twice, or happen to click several times (because you don't get any feedback about this task, it's not shown), the logs for foreman say:

2017-01-16T17:13:30 6b890d82 [app] [E] ForemanTasks::Lock::LockConflict: Required lock is already taken by other running tasks. | Please inspect their state, fix their errors and resume them. | | Required lock: read | Conflicts with tasks: | - http://mandy-rheaves.sat.lab.tlv.redhat.com/foreman_tasks/tasks/99253eb6-a6dc-47ff-9725-7c2e2e1f9e9b

(or similar)

The page should give better feedback about what's going on, as users may wonder why they click on refresh but nothing happens (the error can only be seen on the logs).


Related issues

Is duplicate of Katello - Bug #20244: Clicking Refresh Manifest Does Not Give FeedbackClosed2017-07-07

History

#1 Updated by Justin Sherrill over 5 years ago

  • Assignee set to Thomas McKay
  • Legacy Backlogs Release (now unused) set to 114
  • Difficulty set to easy

#2 Updated by The Foreman Bot almost 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6874 added

#3 Updated by Walden Raines almost 5 years ago

  • Status changed from Ready For Testing to Duplicate

#4 Updated by Walden Raines almost 5 years ago

  • Is duplicate of Bug #20244: Clicking Refresh Manifest Does Not Give Feedback added

#5 Updated by Eric Helms almost 5 years ago

  • Legacy Backlogs Release (now unused) deleted (114)

#6 Updated by Justin Sherrill almost 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF