Project

General

Profile

Bug #22443

Evaluation Error: Error while evaluating a Resource Statement, Duplicate declaration:

Added by Johannes Black almost 3 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I get a

[ERROR 2018-01-29 13:45:13 main] Evaluation Error: Error while evaluating a Resource Statement, Duplicate declaration: File[/etc/puppetlabs/puppet/ssl/private_keys] is already declared in file /usr/share/foreman-installer/modules/foreman_proxy/manifests/config.pp:145; cannot redeclare at /usr/share/foreman-installer/modules/puppet/manifests/server/config.pp:140 at /usr/share/foreman-installer/modules/puppet/manifests/server/config.pp:140:3 on node foreman.ontram.de

after trying to install Foreman with foreman-installer.


Related issues

Is duplicate of Katello - Bug #18806: Duplicate declaration: /etc/foreman-proxy/ssl_key.pemClosed

History

#1 Updated by Johannes Black almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 332

#2 Updated by Daniel Lobato Garcia almost 3 years ago

  • Legacy Backlogs Release (now unused) deleted (332)

#3 Updated by Ewoud Kohl van Wijngaarden almost 3 years ago

  • Project changed from Kafo to Installer

Could you share a bit more? Which version of foreman-installer, which options were used (the answer file might be useful to have but feel free to scrub hostnames and usernames/passwords).

#4 Updated by Johannes Black almost 3 years ago

I have upgraded to Foreman 17 RC2 where there are other problems which are reported as well. I think you can close it right now.

I will check out the to be released RC3 for problems that might persist.

Greetings and thanks
jb

#5 Updated by Anonymous almost 3 years ago

  • Status changed from New to Rejected

#6 Updated by Eric Hansen over 2 years ago

Same error, occurs after adding the option --foreman-proxy-puppetca=false to the following installation request. I had run with that option true successfully yesterday, but had problems and was reverting it.

foreman-installer --scenario foreman-proxy-content \
--foreman-proxy-content-parent-fqdn "eh-katello.qa.catalogic.us"\
--foreman-proxy-register-in-foreman "true"\
--foreman-proxy-foreman-base-url "https://eh-katello.qa.catalogic.us"\
--foreman-proxy-trusted-hosts "eh-katello.qa.catalogic.us"\
--foreman-proxy-trusted-hosts "atm-infrastructure-smartproxy-6861.qa.catalogic.us"\
--foreman-proxy-oauth-consumer-key "xxx"\
--foreman-proxy-oauth-consumer-secret "xxx"\
--foreman-proxy-content-certs-tar "/root/atm-infrastructure-smartproxy-6861.qa.catalogic.us.tar"\
--puppet-server-foreman-url "https://eh-katello.qa.catalogic.us" \
--foreman-proxy-puppet=false \
--foreman-proxy-puppetca=false \
--enable-foreman-proxy \
--foreman-proxy-tftp=true \
--foreman-proxy-tftp-servername='10.1.100.61' \
--foreman-proxy-dhcp=true \
--foreman-proxy-dhcp-interface='ens192' \
--foreman-proxy-dhcp-gateway='10.1.100.248' \
--foreman-proxy-dhcp-range='10.1.100.10 10.1.100.60' \
--foreman-proxy-dhcp-nameservers='10.1.100.61' \
--foreman-proxy-dhcp-subnets='10.1.100.0/255.255.255.0' \
--foreman-proxy-dhcp-option-domain='automation.local' \
--foreman-proxy-dhcp-search-domains='automation.local' \
--foreman-proxy-dhcp-pxeserver='10.1.100.61' \
--foreman-proxy-dns=true \
--foreman-proxy-dns-interface='ens192' \
--foreman-proxy-dns-zone='automation.local' \
--foreman-proxy-dns-reverse='100.1.10.in-addr.arpa' \
--foreman-proxy-dns-server='10.1.100.61' \
--foreman-proxy-dns-forwarders='172.20.40.10'

My log snippet showing the error,
[ERROR 2018-05-25 10:00:05 main] Evaluation Error: Error while evaluating a Resource Statement, Duplicate declaration: File[/etc/puppetlabs/puppet/ssl/private_keys] is already declared at (file: /usr/share/foreman-installer/modules/foreman_proxy/manifests/config.pp, line: 150); cannot redeclare (file: /usr/share/foreman-installer/modules/puppet/manifests/server/config.pp, line: 135) (file: /usr/share/foreman-installer/modules/puppet/manifests/server/config.pp, line: 135, column: 3) on node atm-infrastructure-smartproxy-6861.qa.catalogic.us
[ERROR 2018-05-25 10:00:05 main] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:618:in `fail_on_duplicate_type_and_title'
[ERROR 2018-05-25 10:00:05 main] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:142:in `add_one_resource'
[ERROR 2018-05-25 10:00:05 main] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:128:in `block in add_resource'
[ERROR 2018-05-25 10:00:05 main] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:127:in `each'
[ERROR 2018-05-25 10:00:05 main] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:127:in `add_resource'

#7 Updated by Eric Hansen over 2 years ago

I'm running katello 3.6 (underlying 1.17.0)

#8 Updated by Eric Hansen over 2 years ago

Attempted to resolve by adding --no-enable-puppet, same error
This is probably some compatibility issue with the default proxy installation settings not working... trying to make a smart proxy without puppet, using the main katello server for that purpose.

#10 Updated by Ewoud Kohl van Wijngaarden over 2 years ago

  • Is duplicate of Bug #18806: Duplicate declaration: /etc/foreman-proxy/ssl_key.pem added

Also available in: Atom PDF