Project

General

Profile

Bug #23706

Unable to override hostgroup parameters from All hosts => edit host on WebUI

Added by Daniel Lobato Garcia about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
High
Category:
Hosts
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1564740

Description of problem:

when we click on "edit host" from all hosts. edit page showing the default settings with respect to the selected hostgroup. Any change in the parameters does not reflect on WebUI. However, hammer shows updated details.

How reproducible:

- Always

Steps to Reproduce:

1. provision a host with hostgroup
2. change the LE/CV or content-source from WebUI and save it
3. click on edit host again and LE/CV changed to the default one in the hostgroup

Actual results:

- edit page showing values from hostgroup after changing

Expected results:

- changes should be visible on WebUI

Additional info:

- hammer host info shows correct values
- only reproducible in 6.3
- reproducer details added


Related issues

Has duplicate Katello - Bug #24131: Inconsistency in editing a host on web UI Closed2018-07-02
Has duplicate Katello - Bug #23745: On "Edit" host page, Satellite webui shows the "Content Source" value inherited from the HostGroup instead of the one currently set to the host.Duplicate

Associated revisions

Revision 81ecd36f (diff)
Added by Daniel Lobato Garcia about 3 years ago

Fixes #23706 - CV/LE show the right value on Host form

Before this patch, the following situation could happen:

1. Host A is part of a Host Group 'test'. Host A inherits LE/CV 'test'
coming from Host Group 'test'

2. We decide to change the LE/CV of Host A to 'production', either
through the API or the UI.

3. The next time we decide to check the UI, the helper was wrong (this
patch fixes it) and showed the LE/CV from the Host Group 'test'. This is
very confusing and may even cause you to change the LE/CV to from
'production' to 'test' by accident.

Revision 824172c2 (diff)
Added by Daniel Lobato Garcia about 3 years ago

Refs #23706 - Show correct content source

This is basically the same bug we had with CV/LE:

1. Create a host group 'test' with a content source
2. Assign host group 'test' to a host 'A'
3. Clear the content source, or change the content source of 'A'
4. Submit 'A'
5. Edit 'A'

Result: on the UI, 'A' content source will still be the content source
coming from the host group. If you check the API, the host content
source is correct - the one you assigned in step 3.

Expected Result: on the UI, 'A' content source is the one set on step 3

History

#1 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7398 added

#2 Updated by Andrew Kofink about 3 years ago

  • Legacy Backlogs Release (now unused) set to 338
  • Subject changed from Unable to override hostgroup parameters from All hosts => edit host on WebUI to Unable to override hostgroup parameters from All hosts => edit host on WebUI

#3 Updated by Andrew Kofink about 3 years ago

  • Legacy Backlogs Release (now unused) deleted (338)

Reset the release for re-triage because committer requested 3.6 on the PR.

#4 Updated by John Mitsch about 3 years ago

  • Legacy Backlogs Release (now unused) set to 338
  • Category set to Hosts

#5 Updated by Andrew Kofink about 3 years ago

  • Has duplicate Bug #24131: Inconsistency in editing a host on web UI added

#6 Updated by Anonymous about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#7 Updated by The Foreman Bot about 3 years ago

  • Pull request https://github.com/Katello/katello/pull/7533 added

#8 Updated by Daniel Lobato Garcia about 3 years ago

  • Has duplicate Bug #23745: On "Edit" host page, Satellite webui shows the "Content Source" value inherited from the HostGroup instead of the one currently set to the host. added

Also available in: Atom PDF