Project

General

Profile

Bug #24142

Subscriptions page is blank when switching between Orgs

Added by Tomáš Strachota about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1597082

Description of problem:
When user is on Subs page and switches Orgs, the page is not properly refreshed. user is left with a blank page.

Version-Release number of selected component (if applicable):
6.4.0 snap 10

How reproducible:

Steps to Reproduce:
1. Create an org other than Default Org (e.g., Org 123)
2. Upload manifests to both Default org and Org 123
3. Navigate to the Subscriptions page for one of these orgs; assure page renders.
4. Using the Org switcher, choose the other org.

Actual results:
User is given a blank page.

Expected results:
Subscriptions page is reloaded with the proper org context.

Additional info:
The workaround is of course to navigate back to the Subs page via the UI. But as it exists right now, it feels very janky.

Associated revisions

Revision bfd20b92 (diff)
Added by Amir Fefer about 3 years ago

Fixes #24140, #24142 - mount react root from the layout

History

#1 Updated by Tomáš Strachota about 3 years ago

  • Target version set to 219

This is highly related to https://projects.theforeman.org/issues/22568 and both issues share the same root cause. But there are some changes necessare on both subscription and repositories page so I'm keeping the issues separate.

Disregard this comment I got lost in this know of issues :/

#2 Updated by Tomáš Strachota about 3 years ago

  • Related to Bug #22568: RH repos XUI: page crashes when in Any context added

#3 Updated by Tomáš Strachota about 3 years ago

  • Related to deleted (Bug #22568: RH repos XUI: page crashes when in Any context)

#4 Updated by Greg Sutcliffe about 3 years ago

  • Triaged set to No
  • Team Backlog UX added

#5 Updated by Greg Sutcliffe about 3 years ago

  • Target version deleted (219)

#6 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7518 added

#7 Updated by Walden Raines about 3 years ago

  • Target version set to Katello 3.7.0

#8 Updated by Amir Fefer about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF