Project

General

Profile

Bug #24308

Sort order different between Subscriptions and Add Subscriptions page

Added by Walden Raines over 1 year ago. Updated 23 days ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1599313

Description of problem:

The ordering of the subscriptions appears to be different between the two pages. Add Subscriptions seems to be sorted based on Contract #, whereas Subscriptions seems to be sorted by sub name.

Version-Release number of selected component (if applicable):

6.4 snap 10

How reproducible:

Steps to Reproduce:
1. Use a manifest, preferably one containing a large # of subscriptions
2. Note ordering (based on contract number). Navigate to Add Subscriptions and add one sub from those available to you.
3. Navigate back to your Subscriptions page. Look for the subscription you just added.

Actual results:
The ordering is different, and whatever you added will show in the list based on where it lands alphabetically.

Expected results:

Congruent sorting across the two pages, or possibly just documentation noting sort orders.

Additional info:
I don't think this is a critical issue but it's worth looking into.


Related issues

Is duplicate of Katello - Bug #23471: upstream subs should be sorted by nameClosed

History

#1 Updated by Andrew Kofink over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.9.0
  • Priority changed from Normal to Low

#2 Updated by Jonathon Turel over 1 year ago

  • Is duplicate of Bug #23471: upstream subs should be sorted by name added

#3 Updated by Jonathon Turel about 1 year ago

  • Target version changed from Katello 3.9.0 to Katello Backlog

#4 Updated by Justin Sherrill 4 months ago

  • Status changed from New to Closed

#5 Updated by Justin Sherrill 23 days ago

  • Pull request https://github.com/Katello/katello/pull/8321 added

#6 Updated by Jonathon Turel 23 days ago

  • Target version changed from Katello Backlog to Katello 3.14.0

Also available in: Atom PDF