Project

General

Profile

Bug #24554

Per-page setting does not work in RPM and repo listings

Added by Daniel Lobato Garcia over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Content Views
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1612959

Description of problem: In the list of packages in a content view version, the items per page setting does not seem to work.

See this screen recording:

https://drive.google.com/file/d/1cI2NnY8aSik2mjwqLzdvc6JZhPpkPJgZ/view?usp=sharing

Version-Release number of selected component (if applicable): 6.4.0 snap 16

How reproducible: Always

Steps to Reproduce:
1. Create content view with some content
2. On page for content view click a version.
3. Goto "rpm Packages" or YUM repos tab.
4. Change the per-page setting from the default (20) to something else (100)

Actual results: Setting stays at 20.

Expected results: Setting changes to 100

Additional info: This seems to be on the RPM and repos tabs, the errata tab seen.

I didn't see any error in the console.

History

#1 Updated by Justin Sherrill over 1 year ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.9.0
  • Subject changed from Per-page setting does not work in RPM and repo listings to Per-page setting does not work in RPM and repo listings

#2 Updated by Jonathon Turel over 1 year ago

  • Target version changed from Katello 3.9.0 to Katello Backlog

#3 Updated by Jonathon Turel over 1 year ago

  • Target version changed from Katello Backlog to Katello 3.9.0

#4 Updated by Andrew Kofink over 1 year ago

  • Assignee set to Andrew Kofink
  • Status changed from New to Closed
  • Pull request https://github.com/Katello/bastion/pull/237 added

Also available in: Atom PDF