Project

General

Profile

Bug #27949

EL8 fails to boot

Added by James Shewey 10 months ago. Updated 10 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Templates
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

EL8 fails to boot with the default iPXE template due to the ip= parameter. This is not properly formatted. Per the documentation at https://fedoraproject.org/wiki/Dracut/Options#Network it should be formatted similar to:

ip=${netX/ip}::${netX/gateway}:${netX/netmask}:<%= @host.name %>:eth0:none nameserver=${dns} ifname=eth0:<%= @host.mac %>


Related issues

Related to Foreman - Bug #26749: RHEL 8 with iPXE fails due to Deprecated Options usedClosed

History

#1 Updated by Alexander von Gluck IV 10 months ago

This one was solved in 1.23.0 which works now with katello 1.13

#2 Updated by James Shewey 10 months ago

Ah, OK. I am on Foreman 1.22

#3 Updated by Si Man 10 months ago

If you don't want to upgrade yet, you can just download the relevant templates from https://github.com/theforeman/community-templates.

In my case I just updated Kickstart default (provisioning) and Kickstart default iPXE (iPXE)

#4 Updated by Ondřej Pražák 10 months ago

  • Category set to Templates
  • Project changed from Templates to Foreman

#5 Updated by Lukas Zapletal 10 months ago

  • Triaged changed from No to Yes
  • Status changed from New to Duplicate

Closing as dupe of #26749

#6 Updated by Lukas Zapletal 10 months ago

  • Related to Bug #26749: RHEL 8 with iPXE fails due to Deprecated Options used added

Also available in: Atom PDF