Project

General

Profile

Bug #28423

Subscriptions page blank with JS error

Added by Ian Ballou 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

The subscriptions page with the latest Foreman and Katello upstream is blank and has JS errors.

Here are the JS errors:

Warning: Failed context type: The context `router` is marked as required in `LinkContainer`, but its value is `undefined`.
    in LinkContainer (created by SubscriptionsToolbar)
    in div (created by FormGroup)
    in FormGroup (created by SubscriptionsToolbar)
    in div (created by SubscriptionsToolbar)
    in form (created by Form)
    in Form (created by SubscriptionsToolbar)
    in div (created by Col)
    in Col (created by SubscriptionsToolbar)
    in div (created by Row)
    in Row (created by SubscriptionsToolbar)
    in SubscriptionsToolbar (created by SubscriptionsPage)
    in div (created by Col)
    in Col (created by SubscriptionsPage)
    in div (created by Row)
    in Row (created by SubscriptionsPage)
    in div (created by Grid)
    in Grid (created by SubscriptionsPage)
    in SubscriptionsPage (created by ConnectFunction)
    in ConnectFunction (created by Headers)
    in Headers (created by CheckOrg)
    in CheckOrg (created by ConnectFunction)
    in ConnectFunction (created by Context.Consumer)
    in Route
    in div
    in Unknown (created by Application)
    in Router (created by BrowserRouter)
    in BrowserRouter (created by Application)
    in Application (created by ConnectFunction)
    in ConnectFunction (created by I18nProviderWrapper(Connect(Application)))
    in IntlProvider (created by I18nProviderWrapper(Connect(Application)))
    in I18nProviderWrapper(Connect(Application)) (created by StoreProvider(I18nProviderWrapper(Connect(Application))))
    in Provider (created by StoreProvider(I18nProviderWrapper(Connect(Application))))
    in StoreProvider(I18nProviderWrapper(Connect(Application))) (created by DataProvider(StoreProvider(I18nProviderWrapper(Connect(Application)))))
    in DataProvider(StoreProvider(I18nProviderWrapper(Connect(Application)))) foreman-vendor.bundle-v3.4.0-development-0660968ef5550d1253d4.js:205943:15
TypeError: this.context.router is undefined
foreman-vendor.bundle-v3.4.0-development-0660968ef5550d1253d4.js:269705:16
The above error occurred in the <LinkContainer> component:
    in LinkContainer (created by SubscriptionsToolbar)
    in div (created by FormGroup)
    in FormGroup (created by SubscriptionsToolbar)
    in div (created by SubscriptionsToolbar)
    in form (created by Form)
    in Form (created by SubscriptionsToolbar)
    in div (created by Col)
    in Col (created by SubscriptionsToolbar)
    in div (created by Row)
    in Row (created by SubscriptionsToolbar)
    in SubscriptionsToolbar (created by SubscriptionsPage)
    in div (created by Col)
    in Col (created by SubscriptionsPage)
    in div (created by Row)
    in Row (created by SubscriptionsPage)
    in div (created by Grid)
    in Grid (created by SubscriptionsPage)
    in SubscriptionsPage (created by ConnectFunction)
    in ConnectFunction (created by Headers)
    in Headers (created by CheckOrg)
    in CheckOrg (created by ConnectFunction)
    in ConnectFunction (created by Context.Consumer)
    in Route
    in div
    in Unknown (created by Application)
    in Router (created by BrowserRouter)
    in BrowserRouter (created by Application)
    in Application (created by ConnectFunction)
    in ConnectFunction (created by I18nProviderWrapper(Connect(Application)))
    in IntlProvider (created by I18nProviderWrapper(Connect(Application)))
    in I18nProviderWrapper(Connect(Application)) (created by StoreProvider(I18nProviderWrapper(Connect(Application))))
    in Provider (created by StoreProvider(I18nProviderWrapper(Connect(Application))))
    in StoreProvider(I18nProviderWrapper(Connect(Application))) (created by DataProvider(StoreProvider(I18nProviderWrapper(Connect(Application)))))
    in DataProvider(StoreProvider(I18nProviderWrapper(Connect(Application))))

Consider adding an error boundary to your tree to customize error handling behavior.
Visit https://fb.me/react-error-boundaries to learn more about error boundaries. foreman-vendor.bundle-v3.4.0-development-0660968ef5550d1253d4.js:252743:13
Warning: Can't perform a React state update on an unmounted component. This is a no-op, but it indicates a memory leak in your application. To fix, cancel all subscriptions and asynchronous tasks in the componentWillUnmount method.
    in LoadingState (created by SubscriptionsTable)
    in SubscriptionsTable (created by SubscriptionsPage)
    in div (created by SubscriptionsPage)
    in div (created by Col)
    in Col (created by SubscriptionsPage)
    in div (created by Row)
    in Row (created by SubscriptionsPage)
    in div (created by Grid)
    in Grid (created by SubscriptionsPage)
    in SubscriptionsPage (created by ConnectFunction)
    in ConnectFunction (created by Headers)
    in Headers (created by CheckOrg)
    in CheckOrg (created by ConnectFunction)
    in ConnectFunction (created by Context.Consumer)
    in Route
    in div
    in Unknown (created by Application)
    in Router (created by BrowserRouter)
    in BrowserRouter (created by Application)
    in Application (created by ConnectFunction)
    in ConnectFunction (created by I18nProviderWrapper(Connect(Application)))
    in IntlProvider (created by I18nProviderWrapper(Connect(Application)))
    in I18nProviderWrapper(Connect(Application)) (created by StoreProvider(I18nProviderWrapper(Connect(Application))))
    in Provider (created by StoreProvider(I18nProviderWrapper(Connect(Application))))
    in StoreProvider(I18nProviderWrapper(Connect(Application))) (created by DataProvider(StoreProvider(I18nProviderWrapper(Connect(Application)))))
    in DataProvider(StoreProvider(I18nProviderWrapper(Connect(Application))))

Associated revisions

Revision f6bfa939 (diff)
Added by Ron Lavi 4 months ago

Fixes #28423 - bump react-router-bootstrap

bump react-router-bootstrap in foreman vendor-core
to the latest version (released 9 months ago)
and it seem to solve the issue

History

#1 Updated by Walden Raines 4 months ago

  • Category set to Web UI

#2 Updated by Chris Roberts 4 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.15.0

#3 Updated by Walden Raines 4 months ago

This seems to be caused by upgrading vendor to v3 (https://github.com/Katello/katello/pull/8430).

#4 Updated by The Foreman Bot 4 months ago

  • Assignee set to Ron Lavi
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8476 added

#5 Updated by The Foreman Bot 4 months ago

  • Fixed in Releases Katello 3.15.0 added

#6 Updated by Ron Lavi 4 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF