Project

General

Profile

Bug #30389

Second Pulp 3 yum repo sync "empties" the repository

Added by Jonathon Turel 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

James and I have this in our dev envs:

- sync a yum repo (I was using pulp3) and note its content counts
- set katello_applicability to 'true' in config/settings.plugins.d/katello.yml
- sync the above repo again, notice its content counts have been cleared out


Related issues

Related to Katello - Bug #30532: Pulp_rpm 3.5 does not return Package Groups tied to Package EnvironmentsClosed

Associated revisions

Revision 084dd3e7 (diff)
Added by Samir Jha 3 months ago

Fixes #30389 - Optimze false for repo syncs

(cherry picked from commit 9d667531ec35487f02d8ad4256782662b95af070)

History

#1 Updated by Jonathon Turel 3 months ago

  • Subject changed from Setting katello_applicability to true empties repos on on subsequent sync to Setting katello_applicability to true empties repos on subsequent sync

#2 Updated by Jonathon Turel 3 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.16.0

#3 Updated by Steven M 3 months ago

I think this is the same issue: https://community.theforeman.org/t/katello-3-16-rc4-repository-synchronisation-issues/19593 : empty repo on second synchronization.

What I have seen is that on 3.15 the /var/lib/pulp directory contains:
0005_puppet_module_name_change.txt
assets
content
docroot
katello-export
packages
published
static
tmp
uploads

On a fresh 3.16 RC4, content is missing:
0005_puppet_module_name_change.txt
assets
docroot
katello-export
packages
published
static
tmp
uploads

On initial synchronization, all repository rpms are put into docroot and never transferred to content as in 3.15.

I hope this helps a bit.

#4 Updated by Ian Ballou 3 months ago

Katello 3.16 is now using Pulp 3 so it's expected for the content folder to be missing. I have a feeling that the issue is related to a second sync causing the repo's Pulp 3 version_href to change incorrectly in Katello. The incorrect version_href would explain the empty content units for the repo. Just an idea, we'll have to test it.

Since Steven M saw this issue without touching katello_applicability, it might not be related to that setting.

#5 Updated by Ian Ballou 3 months ago

After a quick check, it appears that the second sync is incrementing the version_href from version 1 to 2. The repo version 2 is empty, so no content is indexed and the repo appears to be empty. We'll just need to stop that version_href from changing incorrectly.

#6 Updated by Ian Ballou 3 months ago

  • Subject changed from Setting katello_applicability to true empties repos on subsequent sync to Second Pulp 3 yum repo sync "empties" the repository

#7 Updated by Justin Sherrill 3 months ago

This is a pulp issue, we'll track this here to ensure it gets fixed in 3.16 or we add a workaround

#9 Updated by The Foreman Bot 3 months ago

  • Assignee set to Samir Jha
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/8873 added

#10 Updated by The Foreman Bot 3 months ago

  • Pull request https://github.com/Katello/katello/pull/8869 added

#11 Updated by The Foreman Bot 3 months ago

  • Fixed in Releases Katello 3.18.0 added

#12 Updated by Samir Jha 3 months ago

  • Status changed from Ready For Testing to Closed

#13 Updated by Jonathon Turel 2 months ago

  • Pull request deleted (https://github.com/Katello/katello/pull/8869)

#14 Updated by Jonathon Turel 2 months ago

  • Related to Bug #30532: Pulp_rpm 3.5 does not return Package Groups tied to Package Environments added

Also available in: Atom PDF