Project

General

Profile

Actions

Feature #32246

closed

Support global download_concurrency setting and default to 5

Added by Justin Sherrill about 3 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Today we have a download concurrency option on a per repo basis, defaulting to pulp's default of 10. With ~6 workers this causes server disconnects. We need to a) make this easier for the user to change, b) lower the default (probably to 5).

I propose that we:

1) add a new content 'Setting' for default_download_concurrency, which defaults to 5
2) keep the per-repo setting, and if it is set use that, if its zero or not set, use the Setting

We can rely on the remote updating as part of https://github.com/Katello/katello/pull/9255 to update the remote on next sync, no need to do that as part of setting update


Related issues 1 (0 open1 closed)

Is duplicate of Katello - Bug #30488: Make download_concurrency configurable in pulpcoreClosedSamir JhaActions
Actions #1

Updated by Jonathon Turel about 3 years ago

  • Target version set to Katello 4.1.0
  • Triaged changed from No to Yes
Actions #2

Updated by Justin Sherrill about 3 years ago

  • Is duplicate of Bug #30488: Make download_concurrency configurable in pulpcore added
Actions #3

Updated by Justin Sherrill about 3 years ago

  • Status changed from New to Duplicate
Actions

Also available in: Atom PDF